• PAT 甲级 1054 The Dominant Color (20 分)(简单题)


    1054 The Dominant Color (20 分)
     

    Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution Mby N (for example, 8), you are supposed to point out the strictly dominant color.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤) and N (≤) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, simply print the dominant color in a line.

    Sample Input:

    5 3
    0 0 255 16777215 24
    24 24 0 0 24
    24 0 24 24 24
    

    Sample Output:

    24

    题意:

    数数哪个颜色过半

    AC代码:

    #include<iostream>
    #include<stack>
    #include<queue>
    #include<cmath>
    #include<algorithm>
    #include<vector>
    #include<string>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    int a[99999999];
    int main(){
        int n,m;
        cin>>n>>m;
        int last=-1;
        for(int i=1;i<=m;i++){
            for(int j=1;j<=n;j++){
                int x;
                cin>>x;
                a[x]++;
                if(a[x]>n*m/2){
                    last=x;
                }
    
            }
        }
        cout<<last;
        return 0;
    }
  • 相关阅读:
    VS中常用设置记录
    MSBUILD结合批处理编译
    Linq to XML 基本类
    在Winform和WPF中注册全局快捷键
    Unity 配置文件 基本设置
    C# 通用Clone
    三次样条插值特点与实现 (引用了一点别人代码,但做了改动!)
    修正短时自相关函数
    矩阵的基本运算
    去红眼不完善 MATLAB 代码
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/11542676.html
Copyright © 2020-2023  润新知