• 杭州电 1052 Tian Ji -- The Horse Racing(贪婪)


    http://acm.hdu.edu.cn/showproblem.php?

    pid=1052

    Tian Ji -- The Horse Racing

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 18058    Accepted Submission(s): 5239


    Problem Description
    Here is a famous story in Chinese history.

    "That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

    "Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

    "Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

    "Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

    "It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



    Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

    However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

    In this problem, you are asked to write a program to solve this special case of matching problem.
     

    Input
    The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
     

    Output
    For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
     

    Sample Input
    3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
     

    Sample Output
    200 0 0




    AC代码:

    <span style="font-size:24px;">#include<iostream>
    #include<algorithm>
    using namespace std;
    int T[1005],K[1005];
    
    bool cmp(int x,int y)
    {
        return x>y;
    }
    
    int main()
    {
        int n;
        while(cin>>n&&n)
        {
            int i,ti,tj,ki,kj,grade=0;
            for(i=0;i<n;i++)
                cin>>T[i];
            for(i=0;i<n;i++)
                cin>>K[i];
            sort(T,T+n,cmp);
            sort(K,K+n,cmp);
            ti=ki=0;
            tj=kj=n-1;
            for(i=0;i<n;i++)
            {
                if(T[ti]>K[ki])//假设田忌最快的马比齐王最快的马快,直接比。

    { ti++; ki++; grade+=200; } else if(T[ti]<K[ki])//假设田忌最快的马比齐王的慢。就拿田忌最差的马跟齐王最快的马比。

    { tj--; ki++; grade-=200; } else { if(T[tj]>K[kj])//假设田忌最慢的马比齐王最慢的马快,直接比。 { tj--; kj--; grade+=200; } else if(T[tj]<K[kj])//假设田忌最慢的马比齐王最慢的还慢,拿这马跟齐王最快的比。 { tj--;ki++; grade-=200; } else { if(T[tj]<K[ki])//田忌最慢的比齐王最快的慢。直接比。 { tj--; ki++; grade-=200; } } } } cout<<grade<<endl; } return 0; } </span>



    版权声明:本文博客原创文章。博客,未经同意,不得转载。

  • 相关阅读:
    POJ-2478 Farey Sequence(欧拉函数)
    BZOJ-1103: [POI2007]大都市meg(树状数组)
    NOIP2016模拟 星际争霸(二分)
    HDU-1222 Wolf and Rabbit (欧几里得定理)
    POJ-2689 Prime Distance(线性筛法)
    FZU-2134 上车(树状数组)
    FZU-2236 第十四个目标(树状数组)
    2016年11月12日00:14:27
    FZU-1921 栀子花开(线段树)
    BZOJ3132 上帝造题的七分钟
  • 原文地址:https://www.cnblogs.com/bhlsheji/p/4659107.html
Copyright © 2020-2023  润新知