• HDOJ 1047 Integer Inquiry



    JAVA睑板....

    Integer Inquiry

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 12042    Accepted Submission(s): 3037


    Problem Description
    One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
    ``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) 
     

    Input
    The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). 

    The final input line will contain a single zero on a line by itself.
     

    Output
    Your program should output the sum of the VeryLongIntegers given in the input. 


    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.
     

    Sample Input
    1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
     

    Sample Output
    370370367037037036703703703670
     

    Source
     


    import java.util.*;
    import java.math.*;
    
    public class Main
    {
    	public static void main(String[] args)
    	{
    		Scanner cin= new Scanner(System.in);
    		int n=cin.nextInt();
    		boolean flag=false;
    		while(n-->0)
    		{
    			if(flag==false) flag=true;
    			else System.out.println("");
    			BigInteger ans=BigInteger.ZERO;
    			while(cin.hasNextBigInteger())
    			{
    				BigInteger m=cin.nextBigInteger();
    				if(m.equals(BigInteger.ZERO))
    					break;
    				ans=ans.add(m);
    			}
    			System.out.println(ans);
    		}
    	}
    }



    版权声明:本文博客原创文章,博客,未经同意,不得转载。

  • 相关阅读:
    ros论坛
    python--dict和set类型--4
    python--条件判断和循环--3
    python--list和tuple类型--2
    Unicode与UTF-8互转(C语言实现)
    spring mvc 返回JSON数据
    值得学习的C语言开源项目和库
    mudos源码分析
    Freemarker使用总结
    Maven详解
  • 原文地址:https://www.cnblogs.com/bhlsheji/p/4637162.html
Copyright © 2020-2023  润新知