• HDOJ 1047 Integer Inquiry



    JAVA睑板....

    Integer Inquiry

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 12042    Accepted Submission(s): 3037


    Problem Description
    One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
    ``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) 
     

    Input
    The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). 

    The final input line will contain a single zero on a line by itself.
     

    Output
    Your program should output the sum of the VeryLongIntegers given in the input. 


    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.
     

    Sample Input
    1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
     

    Sample Output
    370370367037037036703703703670
     

    Source
     


    import java.util.*;
    import java.math.*;
    
    public class Main
    {
    	public static void main(String[] args)
    	{
    		Scanner cin= new Scanner(System.in);
    		int n=cin.nextInt();
    		boolean flag=false;
    		while(n-->0)
    		{
    			if(flag==false) flag=true;
    			else System.out.println("");
    			BigInteger ans=BigInteger.ZERO;
    			while(cin.hasNextBigInteger())
    			{
    				BigInteger m=cin.nextBigInteger();
    				if(m.equals(BigInteger.ZERO))
    					break;
    				ans=ans.add(m);
    			}
    			System.out.println(ans);
    		}
    	}
    }



    版权声明:本文博客原创文章,博客,未经同意,不得转载。

  • 相关阅读:
    新手找客户,牢记20句话
    我国第二套人民币纸分币明天起停止流通
    新病毒仿"熊猫烧香" 利用 Vista系统漏洞疯狂传播
    开发新客户的5个巧招
    Google推出语音本地搜索 与微软展开竞争
    最近大牛生病了
    成功创业的“六字真言”
    ios的AutoresizingMask
    ASIHttpRequest 详细解析
    How to get md5 and SHA1 in objective c (iOS sdk)
  • 原文地址:https://www.cnblogs.com/bhlsheji/p/4637162.html
Copyright © 2020-2023  润新知