• 2017.5.2下午


    Packet Tracer 5.0实验() 路由器RIP动态路由配置

    http://www.cnblogs.com/mchina/archive/2012/07/18/2597618.html

    一、实验目标

    • 掌握RIP协议的配置方法;
    • 掌握查看通过动态路由协议RIP学习产生的路由;
    • 熟悉广域网线缆的连接方式;

    二、实验背景

    假设校园网通过一台三层交换机连到校园网出口路由器上,路由器再和校园外的另一台路由器连接。现要做适当配置,实现校园网内部主机与校园网外部主机之间的相互通信。为了简化网管的管理维护工作,学校决定采用RIP V2协议实现互通。

    三、技术原理

    RIP(Routing Information Protocols),路由信息协议,是应用较早、使用较普通的IGP内部网关协议,适用于小型同类网络,是距离矢量协议;

    RIP协议以跳数衡量路径开销,RIP协议里规定最大跳数为15;

    RIP协议有两个版本:RIPv1和RIPv2,RIPv1属于有类路由协议,不支持VLSM,以广播形式进行路由信息的更新,更新周期为30秒;RIPv2属于无类路由协议,支持VLSM,以组播形式进行路由更新。

    四、实验步骤

    实验拓扑

    1、在三层交换机上划分VLAN10和VLAN20,其中VLAN10用于连接校园网主机,VLAN20用于连接R1;

    2、路由器之间通过V.35电缆通过串口连接,DCE端连接在R1上,配置其时间频率为64000;

    3、主机和交换机通过直连线连接,主机与路由器通过交叉线连接;

    4、在S3560上配置RIPv2路由协议;

    5、在路由器R1、R2上配置RIPv2路由协议;

    6、将PC1、PC2主机默认网关分别设置为与直连网络设备接口IP地址;

    7、验证PC1、PC2主机之间可以互相通信;

    S3560:

    复制代码
    Switch>
    Switch>en
    Switch#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#hostname S3560
    S3560(config)#vlan 10
    S3560(config-vlan)#exit
    S3560(config)#vlan 20
    S3560(config-vlan)#exit
    S3560(config)#interface fa0/10
    S3560(config-if)#switchport access vlan 10
    S3560(config-if)#exit
    S3560(config)#interface fa0/20
    S3560(config-if)#switchport access vlan 20
    S3560(config-if)#exit
    S3560(config)#interface vlan 10
    
    %LINK-5-CHANGED: Interface Vlan10, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
    S3560(config-if)#ip address 192.168.1.1 255.255.255.0
    S3560(config-if)#exit
    S3560(config)#interface vlan 20
    %LINK-5-CHANGED: Interface Vlan20, changed state to up S3560(config-if)#ip address 192.168.3.1 255.255.255.0 S3560(config-if)#exit S3560(config)#router rip S3560(config-router)#network 192.168.1.0 S3560(config-router)#network 192.168.3.0 S3560(config-router)#version 2 S3560(config-router)# %LINK-5-CHANGED: Interface FastEthernet0/20, changed state to up %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/20, changed state to up %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up S3560(config-router)#end S3560# %SYS-5-CONFIG_I: Configured from console by console S3560#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route Gateway of last resort is not set C 192.168.1.0/24 is directly connected, Vlan10 C 192.168.3.0/24 is directly connected, Vlan20 S3560#show ip route //当配置好所有RIPv2后,再查看路由信息 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route Gateway of last resort is not set C 192.168.1.0/24 is directly connected, Vlan10 R 192.168.2.0/24 [120/2] via 192.168.3.2, 00:00:01, Vlan20 C 192.168.3.0/24 is directly connected, Vlan20 R 192.168.4.0/24 [120/1] via 192.168.3.2, 00:00:01, Vlan20 S3560#
    复制代码

    R1:

    复制代码
    Router>en
    Router#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#hostname R1
    R1(config)#interface fa0/0
    R1(config-if)#no shutdown 
    
    %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    
    R1(config-if)#ip address 192.168.3.2 255.255.255.0
    R1(config-if)#exit
    R1(config)#interface serial 2/0
    R1(config-if)#no shutdown 
    
    %LINK-5-CHANGED: Interface Serial2/0, changed state to down
    R1(config-if)#clock rate 64000
    R1(config-if)#ip address 192.168.4.1 255.255.255.0
    R1(config-if)#exit
    R1(config)#router rip
    R1(config-router)#network 192.168.3.0
    R1(config-router)#network 192.168.4.0
    R1(config-router)#version 2
    R1(config-router)#end
    
    %SYS-5-CONFIG_I: Configured from console by console
    R1#show ip route 
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
    R    192.168.1.0/24 [120/1] via 192.168.3.1, 00:00:15, FastEthernet0/0
    C    192.168.3.0/24 is directly connected, FastEthernet0/0
    R1#
    %LINK-5-CHANGED: Interface Serial2/0, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
    
    R1#show ip route                                                             //当配置好所有RIPv2后,再查看路由信息 
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
    R    192.168.1.0/24 [120/1] via 192.168.3.1, 00:00:19, FastEthernet0/0
    R    192.168.2.0/24 [120/1] via 192.168.4.2, 00:00:11, Serial2/0
    C    192.168.3.0/24 is directly connected, FastEthernet0/0
    C    192.168.4.0/24 is directly connected, Serial2/0
    R1#
    复制代码

    R2:

    复制代码
    Router>en
    Router#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#hostname R2
    R2(config)#interface fa0/0
    R2(config-if)#no shutdown 
    
    %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    
    R2(config-if)#ip address 192.168.2.1 255.255.255.0
    R2(config-if)#exit
    R2(config)#interface serial 2/0
    R2(config-if)#no shutdown 
    
    %LINK-5-CHANGED: Interface Serial2/0, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
        
    R2(config-if)#ip address 192.168.4.2 255.255.255.0
    R2(config-if)#exit
    R2(config)#end
    
    %SYS-5-CONFIG_I: Configured from console by console
    R2#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
    C    192.168.2.0/24 is directly connected, FastEthernet0/0
    C    192.168.4.0/24 is directly connected, Serial2/0
    R2#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    R2(config)#router rip
    R2(config-router)#network 192.168.2.0
    R2(config-router)#network 192.168.4.0
    R2(config-router)#version 2
    R2(config-router)#end
    
    %SYS-5-CONFIG_I: Configured from console by console
    R2#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
    R    192.168.1.0/24 [120/2] via 192.168.4.1, 00:00:00, Serial2/0
    C    192.168.2.0/24 is directly connected, FastEthernet0/0
    R    192.168.3.0/24 [120/1] via 192.168.4.1, 00:00:00, Serial2/0
    C    192.168.4.0/24 is directly connected, Serial2/0
    R2#
    复制代码

    五、测试

    复制代码
    Packet Tracer PC Command Line 1.0
    PC>ipconfig
    
    IP Address......................: 192.168.2.2
    Subnet Mask.....................: 255.255.255.0
    Default Gateway.................: 192.168.2.1
    
    PC>ping 192.168.1.2
    
    Pinging 192.168.1.2 with 32 bytes of data:
    
    Request timed out.
    Request timed out.
    Reply from 192.168.1.2: bytes=32 time=16ms TTL=125
    Reply from 192.168.1.2: bytes=32 time=17ms TTL=125
    
    Ping statistics for 192.168.1.2:
        Packets: Sent = 4, Received = 2, Lost = 2 (50% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 16ms, Maximum = 17ms, Average = 16ms
    
    PC>ping 192.168.1.2
    
    Pinging 192.168.1.2 with 32 bytes of data:
    
    Reply from 192.168.1.2: bytes=32 time=19ms TTL=125
    Reply from 192.168.1.2: bytes=32 time=16ms TTL=125
    Reply from 192.168.1.2: bytes=32 time=13ms TTL=125
    Reply from 192.168.1.2: bytes=32 time=15ms TTL=125
    
    Ping statistics for 192.168.1.2:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 13ms, Maximum = 19ms, Average = 15ms
    
    PC>
    复制代码
  • 相关阅读:
    PAT甲级1114. Family Property
    PAT甲级1111. Online Map
    Android零基础入门第84节:引入Fragment原来是这么回事
    Android零基础入门第83节:Activity间数据传递方法汇总
    Android零基础入门第82节:Activity数据回传
    Android零基础入门第81节:Activity数据传递
    Android零基础入门第80节:Intent 属性详解(下)
    Android零基础入门第79节:Intent 属性详解(上)
    Android零基础入门第78节:四大组件的纽带——Intent
    Android零基础入门第77节:Activity任务栈和启动模式
  • 原文地址:https://www.cnblogs.com/bgd140206121/p/6796932.html
Copyright © 2020-2023  润新知