• hdu Air Raid


    Air Raid

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 72    Accepted Submission(s): 61
     
    Problem Description
    Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles.
    With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.
     
    Input
    Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:
    no_of_intersections no_of_streets S1 E1 S2 E2 ...... Sno_of_streets Eno_of_streets
    The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.
    There are no blank lines between consecutive sets of data. Input data are correct.
     
    Output
                The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.
     
    Sample Input
    2
    4
    3
    3 4
    1 3
    2 3
    3
    3
    1 3
    1 2
    2 3
     
    Sample Output
    2
    1
     
     
    Source
    Asia 2002, Dhaka (Bengal)
     
    Recommend
    Ignatius.L
     

    分析:有向图的最小路径覆盖=节点数-最大匹配。

    #include<cstdio>
    #include<cstring>
    #define maxn 151
    
    typedef struct S {
        int v;
        struct S *next;
    } NODE;
    NODE *node[maxn], temp[100 * maxn], *edge[maxn];
    int cnt;
    
    void add(int a, int b) {
        temp[cnt].v = b;
        temp[cnt].next = node[a];
        node[a] = &temp[cnt++];
    }
    int vis[maxn], match[maxn];
    
    int dfs(int a) {
        int b;
        edge[a] = node[a];
        for (; edge[a]; edge[a] = edge[a]->next) {
            b = edge[a]->v;
            if (vis[b])
                continue;
            vis[b] = 1;
            if (match[b] == -1 || dfs(match[b])) {
                match[b] = a;
                return 1;
            }
        }
        return 0;
    }
    
    int main() {
        int n, i, j, m, a, b, ans, T;
        scanf("%d", &T);
        while (T--) {
            scanf("%d%d", &n, &m);
            for (i = 0; i < n; ++i)
                node[i] = NULL;
            ans = 0;
            cnt = 0;
            memset(match, -1, sizeof (match));
            for (i = 0; i < m; ++i) {
                scanf("%d %d", &a, &b);
                add(a - 1, b - 1);
            }
            for (i = 0; i < n; ++i) {
                memset(vis, 0, sizeof (vis));
                if (dfs(i))
                    ++ans;
            }
            printf("%d\n", n - ans);
        }
        return 0;
    }
    这条路我们走的太匆忙~拥抱着并不真实的欲望~
  • 相关阅读:
    LoadRunner12 Java Vuser API语法举例
    Java代码封装redis工具类
    Java代码redis基础操作
    Git提交代码失败: empty ident name (for <>) not allowed
    Ubuntu 16.04 root环境变量不生效问题解决方案
    Jenkins中使用GitLab的配置
    gitlab搭建与配置说明
    移动端网页开发经验总结 (不断更新ing)
    移动端开发注意事项(转载)
    电脑上调试手机网站的几种方法
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2710060.html
Copyright © 2020-2023  润新知