• HDOJ-三部曲-多重背包-1014-Cash Machine


    通过这道题我基本了解了利用二进制对多重背包问题进行优化的思想。

    Cash Machine
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 24191   Accepted: 8466

    Description

    A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,
    N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10
    means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 
    Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 
    Notes: @ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

    Input

    The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:
    cash N n1 D1 n2 D2 ... nN DN
    where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination,  1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

    Output

    For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

    Sample Input

    735 3  4 125  6 5  3 350
    633 4  500 30  6 100  1 5  0 1
    735 0
    0 3  10 100  10 50  10 10

    Sample Output

    735
    630
    0
    0

    Hint

    The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.  
    In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630.  Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.
    In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

    Source

     
     
     
     
    #include<iostream>
    #include<cstring>
    using namespace std;
    int main()
    {
    	int cash,n;
    	while(cin>>cash>>n)
    	{
    		int i,j,k=0,num[11],den[11],sc[10000];
    		int *dp=new int[100001];
    		memset(dp,0,(cash+1)*sizeof(int));
    		for(i=1;i<=n;i++)
    		{
    			cin>>num[i]>>den[i];
    			int t=1,amount=num[i];
    			while(amount>0)               //用二进制思想进行优化,化为01背包问题
    			{
    				if(amount>=t)
    				{
    					sc[k++]=t*den[i];
    					amount-=t;
    					t*=2;
    				}
    				else
    					t=1;
    			}
    		}
    	/*	for(i=0;i<k;i++)
    			cout<<sc[i]<<' ';
    		cout<<endl;*/
    		for(i=0 ;i<k;i++)
    			for(j=cash;j>=sc[i];j--)
    				dp[j]=max(dp[j],dp[j-sc[i]]+sc[i]);
    		cout<<dp[cash]<<endl;
    		delete dp;
    	}
    }
    
  • 相关阅读:
    jenkins 持续集成iOS开发
    CocoaPods 简介
    iOS 10 Programming Fundamentals with Swift 学习笔记 0
    人生,从来没有白走的路
    Oracle数据库备份与恢复命令
    远程备份数据库文件
    恢复误删数据库数据
    Oracle同义词创建及其作用
    同义词使用案例
    ORA-01940无法删除当前已连接用户
  • 原文地址:https://www.cnblogs.com/aljxy/p/3308751.html
Copyright © 2020-2023  润新知