• hdu1541--Stars(树状数组)


    Problem Description
    Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



    For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

    You are to write a program that will count the amounts of the stars of each level on a given map.
     
    Input
    The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
     
    Output
    The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
     
    Sample Input
    5 1 1 5 1 7 1 3 3 5 5
     
    Sample Output
    1 2 1 1 0
     
    #include<iostream>
    #include<algorithm>
    #include<string.h>
    using namespace std;
    int c[32000+10],ans[32000+10];
    int lowbit(int d){
        return d&(-d);
    }
    void update(int x,int d){
        while(x<=3201){
            c[x]+=d;
            x+=lowbit(x);
        }
    }
    int getSum(int x){
        int res=0;
        while(x>0){
            res+=c[x];
            x-=lowbit(x);
        }
        return res;
    }
    
    int main(){
        int n,x,y;
        while(cin>>n){
            memset(ans,0,sizeof(ans));
            memset(c,0,sizeof(c));
            for(int i=0;i<n;i++){
                cin>>x>>y;
                ans[getSum(x+1)]++;
                update(x+1,1);
            }
            for(int i=0;i<n;i++)
                cout<<ans[i]<<endl;
        }
        return 0;
    }

    当前的点的答案是,小于当前x的所有点的个数

  • 相关阅读:
    01 . Nginx简介及部署
    01 . Ansible原理部署及简单应用
    vue css module
    Expected linebreaks to be 'LF' but found 'CRLF'.
    vue SPA设计 history hash
    vue3 createComponent
    vue3 template refs dom的引用、组件的引用、获取子组件的值
    vue3 父组件给子组件传值 provide & inject
    vue3生命周期
    CSS3 transform变换
  • 原文地址:https://www.cnblogs.com/albert67/p/10400270.html
Copyright © 2020-2023  润新知