• nyoj5-Binary String Matching


    Binary String Matching

    时间限制:3000 ms  |  内存限制:65535 KB
    难度:3
    描述
    Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
    输入
    The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
    输出
    For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
    样例输入
    3
    11
    1001110110
    101
    110010010010001
    1010
    110100010101011 
    样例输出
    3
    0
    3 
     
    #include<iostream>
    #include<string>
    using namespace std;
    int main()
    {
    	string s1,s2;
    	int n;
    	cin>>n;
    	while(n--)
    	{
    		cin>>s1>>s2;
    		unsigned int m=s2.find(s1,0);
    		int num=0;
    		while(m!=string::npos)
    		{
    			num++;
    			m=s2.find(s1,m+1);
    		}
    		cout<<num<<endl;
    	}
    }        
    这是标程,之前ac的代码没有了
  • 相关阅读:
    js原生小小总结(二)
    js原生小小总结(一)
    js原生小小总结
    寻找峰值
    第一个错误的版本
    [JSOI2018] 战争
    CF232E Quick Tortoise
    [JLOI2015] 骗我呢
    CF1428G Lucky Numbers
    CF1239E Turtle
  • 原文地址:https://www.cnblogs.com/aerer/p/9931113.html
Copyright © 2020-2023  润新知