• (Dijkstra) POJ1797 Heavy Transportation


    Heavy Transportation
    Time Limit: 3000MS   Memory Limit: 30000K
    Total Submissions: 53170   Accepted: 13544

    Description

    Background 
    Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
    Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

    Problem 
    You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

    Input

    The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

    Output

    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

    Sample Input

    1
    3 3
    1 2 3
    1 3 4
    2 3 5
    

    Sample Output

    Scenario #1:
    4

    注意题目是和求最短路是有点不同的。
    /*审题,这个题是要求从1到n城市最大承载量,而最大承载量就是从城市1到城市n所有通路上的最大承载量,并不是求最短路,
    不过,也可以用Dijkstra求解,只不过需要在求最短路上的Dijkstra模板上改改一些而已*/ 
    #include<iostream>
    #include<cstring>
    #include<algorithm>
    #include<cstdio>
    using namespace std;
    const int maxn = 1010;
    int mp[maxn][maxn],dis[maxn],vis[maxn];
    int edge,node;
    int num;
    void dijkstra(){
        for(int i = 1; i <= node; i++){
            dis[i] = mp[1][i];
        }
        for(int i = 1; i < node; i++){
            int mn = -1,u;
            for(int j = 1; j <= node; j++){
                if(vis[j] == 0 && dis[j] > mn){        //dis[]是为了找到最大承载量。找到没有标记的点。 
                    mn = dis[j];
                    u = j;
                }
            }
            vis[u] = 1;        
            for(int j = 1; j <= node; j++){
                if(vis[j] == 0 && dis[j] < min(dis[u],mp[u][j])){    //松弛,由于最大承载量是有限制,需要要选择最小的。 
                    dis[j] = min(dis[u],mp[u][j]);
                }
            }
        }
        
    }
    int main(){
        int T;
        num = 0;
        scanf("%d",&T);
        while(T--){
            num++;
            scanf("%d%d",&node,&edge);
            for(int i = 1; i <= node; i++){
                for(int j = 1; j <= node; j++){
                    mp[i][j] = 0;        //求最大当然要初始化最小。 
                }
            }
            memset(vis,0,sizeof(vis));
            int m,n,t;
            for(int i = 0; i < edge; i++){
                scanf("%d%d%d",&m,&n,&t);
                mp[m][n] = mp[n][m] = t;    //此题是无向图中求从1到node的最短路。无向图。 
            }
            dijkstra();
            printf("Scenario #%d:
    %d
    
    ",num,dis[node]);
        }
        return 0;
    }
    View Code
  • 相关阅读:
    转 linux下vi命令大全
    转 html5 canvas 详细使用教程
    怎么让手机网站自适应设备屏幕宽度? 转自百度经验
    转 :<meta http-equiv="X-UA-Compatible" content="IE=edge" /> 的说明
    转自haorooms :网页防止黑客跨框架攻击,及浏览器安全性想到的
    元信息标记<meta>
    Java语言的主要特性
    学习面向对象的三条主线之一 java类及类的成员
    1.5 MySQL信息源
    1.4在MySQL 8.0中添加,不建议使用或删除的服务器和状态变量及选项
  • 原文地址:https://www.cnblogs.com/Weixu-Liu/p/10418170.html
Copyright © 2020-2023  润新知