• pat 1035. Password (20)


    1035. Password (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

    Output Specification:

    For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

    Sample Input 1:

    3
    Team000002 Rlsp0dfa
    Team000003 perfectpwd
    Team000001 R1spOdfa
    
    Sample Output 1:
    2
    Team000002 RLsp%dfa
    Team000001 R@spodfa
    
    Sample Input 2:
    1
    team110 abcdefg332
    
    Sample Output 2:
    There is 1 account and no account is modified
    
    Sample Input 3:
    2
    team110 abcdefg222
    team220 abcdefg333
    
    Sample Output 3:
    There are 2 accounts and no account is modified
    解:这题好像没什么。

    代码:

    #include<iostream>
    #include<cstdlib>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int main()
    {
        int num;
        while(scanf("%d",&num)==1)
        {
            int cnt=0;
            int *st=new int[num+1];
            string *id=new string[num+1];
            string *pass=new string[num+1];
            for(int i=0;i<num;i++)
            {
                int g=0;
                cin>>id[i]>>pass[i];
                for(int j=0;j<pass[i].length();j++)
                {
    
                    if(pass[i][j]=='1')
                    {
                        pass[i][j]='@';
                        g=1;
                        continue;
                    }
                    if( pass[i][j]=='0')
                    {
                        pass[i][j]='%';
                        g=1;
                    }
                    if( pass[i][j]=='l')
                    {
                        pass[i][j]='L';
                        g=1;
                    }
                    if( pass[i][j]=='O')
                    {
                        pass[i][j]='o';
                        g=1;
                    }
                }
                if(g==1)
                    st[cnt++]=i;
            }
            if(cnt==0)
            {
                if(num==1)
                {
                    cout<<"There is 1 account and no account is modified"<<endl;
                }
                else
                {
                    cout<<"There are "<<num<<" accounts and no account is modified"<<endl;
                }
            }
            else
            {
                cout<<cnt<<endl;
                for(int i=0;i<cnt;i++)
                {
                    cout<<id[st[i]]<<' '<<pass[st[i]]<<endl;
                }
            }
        }
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    Easy | LeetCode 154 | 剑指 Offer 11. 旋转数组的最小数字 | 二分法
    Easy | 剑指 Offer 17. 打印从1到最大的n位数 | 大数
    Easy | LeetCode 191 | 剑指 Offer 15. 二进制中1的个数 | 位运算
    Easy | 剑指 Offer 57
    Medium | LeetCode 15. 三数之和 | 双指针法
    jq load()方法实现html 模块化。
    vue 剪切图片上传头像,使用 cropperjs 实现
    vue 的nextTick的理解
    使用nodejs进行开发,concurrently模块,使我们同时执行多个命令。
    cookie生命周期expires 时间过期,但是cookie没有被浏览器清理的问题
  • 原文地址:https://www.cnblogs.com/Tobyuyu/p/4965306.html
Copyright © 2020-2023  润新知