• pat 1041. Be Unique (20)


    1041. Be Unique (20)

    时间限制
    100 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

    Input Specification:

    Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

    Output Specification:

    For each test case, print the winning number in a line. If there is no winner, print "None" instead.

    Sample Input 1:
    7 5 31 5 88 67 88 17
    
    Sample Output 1:
    31
    
    Sample Input 2:
    5 888 666 666 888 888
    
    Sample Output 2:
    None
    解:开大数组,还好没卡内存,平稳渡劫。我觉得最关键的点在if(a[b[i]]==1)这里,这里b[i]保证是按照输入值的顺序进行判断的。还有一点值得注意的是:每次while循环时要将整个a数组置零。

    代码:

    #include<iostream>
    #include<cstdlib>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    
    int main()
    {
        int n;
        int a[100000+1];
        while(cin>>n)
        {
            int temp;
            memset(a,0,sizeof(a));
            int *b=new int[n+1];
            for(int i=0;i<n;i++)
            {
                cin>>temp;
                b[i]=temp;
                a[temp]++;
            }
            int tob=0;
            for(int i=0;i<n;i++)
            {
                if(a[b[i]]==1)
                {
                    tob=1;
                    cout<<b[i]<<endl;
                    break;
                }
            }
            if(tob==0)
                cout<<"None"<<endl;
        }
    }


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    《SpringBoot揭秘 快速构建微服务体系》读后感(二)
    《SpringBoot揭秘 快速构建微服务体系》读后感(一)
    《Java多线程编程核心技术》读后感(十八)
    4.Go-结构体、结构体指针和方法
    3.GO-项目结构、包访问权限、闭包和值传递引用传递
    3.Flask-SQLAlchemy
    3.django Model
    2.深入类和对象
    2.shell编程-函数的高级用法
    mysql命令
  • 原文地址:https://www.cnblogs.com/Tobyuyu/p/4965299.html
Copyright © 2020-2023  润新知