• How Many Answers Are Wrong


    How Many Answers Are Wrong Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

    Submit Status

    Description

    TT and FF are ... friends. Uh... very very good friends -________-b

    FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

    Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

    Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

    The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

    However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

    What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

    But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
     

    Input

    Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

    Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

    You can assume that any sum of subsequence is fit in 32-bit integer.
     

    Output

    A single line with a integer denotes how many answers are wrong.
     

    Sample Input

    10 5
    1 10 100
    7 10 28
    1 3 32
    4 6 41
    6 6 1
     

    Sample Output

    1
    首先你要读懂题意,第二行1,10代表1标号到10标号10个数的和是100,以下类似。判断当前话是否与之前的话有矛盾,和食物链类似,r用矢量加减法,箭头指向左端的数,即其根节点。
    #include<iostream>
    #include<cstdio>
    
    using namespace std;
    
    #define N 200005
    
    int f[N], r[N];  // f数组存储下标根节点,r存储下标到根节点(把一棵树上最左边数置为根节点方便判断,的sum
    
    int found(int x)
    {
        int k = f[x];
        if(f[x] != x)
        {
            f[x] = found(f[x]);
            r[x] = r[x]+r[k];  // 根节点在变,r肯定随之改变,就是之前根节点sum,加上根节点到r【f【x】】;
        }
        return f[x];
    }
    
    int main()
    {
        int n, m, a, b, s;
    
        while(cin >> n >> m)
        {
            int cou = 0;
            for(int i = 1; i <= n; i++)
                f[i] = i, r[i] = 0;   // 初始化,最开始f是自身,r是0;
    
            for(int i = 0; i < m; i++)
            {
                cin >> a >> b >> s;
    
                a--;   // 为什么减一,首先你要读懂题意,当要判断3和5之间sum时,你就要用5到相同根节点的sum-2到同根sum(因为爱情=.=||
    
                int na = found(a), nb = found(b);
    
                if(na == nb && (r[a] + s) != r[b])  //  相同根节点时,eg:3,5。就要用2到相同根节点的sum+s(3~5sum,是否等于5~相同根节点sum
                    cou++;
                else if(na > nb)
                {
                    f[na] = nb;
                    r[na] = r[b]-r[a]-s;  // if不在一棵树上(之前没联系,画个三角形箭头指向左边(较小的数,就知道该减还是加了
                }
                else if(na < nb)
                {
                    f[nb] = na;
                    r[nb] = r[a] - r[b] + s;  // 箭头指向较小的数即根节点。
                }
            }
            cout << cou << endl;
        }
        return 0;
    }
    让未来到来 让过去过去
  • 相关阅读:
    CART算法(转)
    分类算法:决策树(C4.5)(转)
    决策树与迭代决策树(转)
    随机森林(Random Forest)详解(转)
    Bagging和Boosting 概念及区别(转)
    迭代器与生成器
    Python代码这样写更优雅(转)
    python进行EDA探索性数据分析
    标准化与归一化(转)
    最小树形图(poj3164)
  • 原文地址:https://www.cnblogs.com/Tinamei/p/4676597.html
Copyright © 2020-2023  润新知