• Uniform Generator


    手动模拟一下就出来了

    Uniform Generator

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 16   Accepted Submission(s) : 6

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

    seed(x+1) = [seed(x) + STEP] % MOD

    where '%' is the modulus operator.

    Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

    For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

    If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

    Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

    Input

    Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

    Output

    For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.

    Sample Input

    3 5
    15 20
    63923 99999
    

    Sample Output

             3         5    Good Choice
    
            15        20    Bad Choice
    
         63923     99999    Good Choice
    


    AC之前你是肯定要PE的,至于几次就看你EQ了

    #include<stdio.h>
    #include<string.h>

    #define N 100008

    int main()
    {
        int seed[N], step, mod, i, div[N];

        while(scanf("%d%d", &step, &mod) != EOF)
        {
            memset(div, 0, sizeof(div));
            memset(seed, 0, sizeof(seed));
            seed[0] = 0;
            for(i = 0; i < N-1; i++)
            {
                seed[i+1] = (seed[i] + step) % mod;
                div[seed[i+1]] = 1; // 把出现过的余数置为1;
                if(seed[i+1] == seed[0])
                    break;
            }
            printf("%10d%10d", step, mod);
            for(i = 0; i < mod; i++)
            {
                if(div[i] == 0) //看这个数是否出现过
                    break;
            }
            if(i < mod)
                printf("    Bad Choice ");
            else
                printf("    Good Choice ");
        }
    }

    ideas:

    越来越发现so easy 了。只要你thinking~~~
    让未来到来 让过去过去
  • 相关阅读:
    set的使用
    dict的使用
    tuple的使用
    Python数据类型字符串
    spring与redis集成之aop整合方案
    MySQL 对于大表(千万级),要怎么优化呢?
    MYSQL千万级数据量的优化方法积累
    Java:按值传递还是按引用传递详细解说
    常用正则表达式
    Java中equals和==的区别
  • 原文地址:https://www.cnblogs.com/Tinamei/p/4455772.html
Copyright © 2020-2023  润新知