• uva 1506 Largest Rectangle in a Histogram


    Largest Rectangle in a Histogram

    http://acm.hdu.edu.cn/showproblem.php?pid=1506

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

    Problem Description
    A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

    Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
     
    Input
    The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
     
    Output
    For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
     
    Sample Input
    7 2 1 4 5 1 3 3
    4 1000 1000 1000 1000
    0
     
    Sample Output
    8
    4000
     
    Source
     
    Recommend
    LL   |   
    We have carefully selected several similar problems for you:  1505 1069 1087 1058 1176 
     
    题意:有n个数ai。从中选出一段区间[L,R],使得(R-L+1)*min{a_L,…,a_R}最大。
    经典广告印刷问题

    考虑对于第i个数,求出当这个数成为最小值时,往左往右分别最远能到哪里。

     使用单调队列来实现这一过程。

     
    #include<cstdio>
    #include<algorithm>
    #define N 100001
    
    #ifdef WIN32
    #define ll "%I64d
    "
    #else
    #define ll "%lld
    "
    #endif
    
    using namespace std;
    int n,a[N],b[N];
    int q[N],tmp[N],head,tail;
    int l[N],r[N];
    long long ans;
    void monotonous(int *c,int *d)
    {
        q[0]=c[1]; tmp[0]=1; 
        head=0; tail=1;
        for(int i=2;i<=n;i++)
        {
            if(c[i]<q[tail-1]) 
                while(head<tail && q[tail-1]>c[i])    d[tmp[--tail]]=i-1;
            q[tail]=c[i];
            tmp[tail++]=i;
        }
        while(head<tail) d[tmp[head++]]=n;
    }
    int main()
    {
        while(scanf("%d",&n)!=EOF)
        {    
            if(!n) return 0;
            ans=0;
            for(int i=1;i<=n;i++) scanf("%d",&a[i]),b[n-i+1]=a[i];
            monotonous(a,r);
            monotonous(b,l);
            for(int i=1;i<=n;i++) tmp[i]=l[i];
            for(int i=1;i<=n;i++) l[n-i+1]=n-tmp[i]+1;
            for(int i=1;i<=n;i++) ans=max(ans,1ll*(r[i]-l[i]+1)*a[i]);
            printf(ll,ans);
        }
    }
  • 相关阅读:
    2016华为实习编程题:停车管理系统
    lintcode:单词切分
    2016网易实习生编程题:数组中两个数的和等于sum
    2016网易实习生编程题:n个骰子的和等于m
    2016百度编程题:钓鱼比赛
    2016百度编程题:裁减网格纸
    2016百度编程题:罪犯转移
    JAVA面试基础
    扔硬币问题
    随机数生成随机数
  • 原文地址:https://www.cnblogs.com/TheRoadToTheGold/p/7300354.html
Copyright © 2020-2023  润新知