• poj 2541 Binary Witch


    Binary Witch
    Time Limit: 1000MS   Memory Limit: 65536K
         

    Description

    Once upon a time in the silent depths of digital forests there lived a Binary Witch. She was able to forecast weather, telling for any day in the future whether it will be rainy or sunny. 

    Her magic was based on the following ancient rule: let a1, a2, ..., aN be the sequence of binary digits, where ai = 0 indicates that i-th day was rainy, and ai = 1 -- that it was sunny. To predict the weather in day N+1, consider the t-postfix aN-t+1, aN-t+2, ..., aN consisting of the last t elements. If that postfix is encountered somewhere before the position N-t+1, i.e. if there is such k <= N-t, that ak = aN-t+1, ak+1 = aN-t+2, ..., ak+t-1 = aN then the predicted value will be ak+t

    If there is more than one occurrence of t-postfix, then the rightmost one (with maximal k) will be taken. So, to make a prediction, she tried t-postfixes, consequently for t = 13, 12, ..., 1, stopping after the first prediction. If neither postfix was found, she predicted rain ("0"). If prediction for more than one day is needed, it is assumed that all previous days are predicted correctly, so if first predicted value is b, then we make forecast for day N+2 based on N+1 values, where aN+1 = b. 

    Because the witch was burned long ago, your task is to write a program to perform her arcane job.

     

    Input

    First line of input file contains two integers N (1 <= N <= 1000000) and L (1 <= L <= 1000), separated by space. Second line contains a string of N characters "0" and "1".
     

    Output

    Output file must contain a single string of L characters, which are forecasts for days N+1, N+2, ..., N+L.

     

    Sample Input

    10 7
    1101110010

     

    Sample Output

    0100100

     

    Source

    Northeastern Europe 2000, Far-Eastern Subregion
     
    题意:
    给一个长为n的字符串s,在前面找到一个长为m(m<=13)的字符串a=后缀
    在m尽量大的前提下,使找到的字符串a尽量靠后
    有则在字符串s末尾添加 字符串a的最后一个字符的后一个字符
    没有则在字符串s末尾添加 0
    连续找L次
    最后输出字符串s的最后L位
     
    逆序kmp
    题目要求统计的是最长后缀,将原字符串翻转,就是最长前缀
    然后对于接下来的每一天做一次kmp
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    
    const int maxn=1000000+1010;
    char s[maxn],str[maxn];
    int next[maxn];
    char ans[1005];
    int n,l;
    int start=1005,len;
    void getnext(char *st)
    {
        int j,lm=strlen(st);
        for(int i=1;i<lm;i++)
        {
            j=next[i];
            while(j&&st[j]!=st[i]) j=next[j];
            next[i+1]= st[i]==st[j] ? j+1 : 0;
        }    
    }
    int kmp(char *p)
    {
        int j=0,c=0,idx;
        int lm=strlen(p);
        for(int i=start+1;i<start+len;i++)
        {
            while(j&&p[j]!=str[i]) j=next[j];
            if(p[j]==str[i]) j++;
            if(j>c) { c=j; idx=i; }
            if(j==lm) return i-j;
        }
        if(c) return idx-c;
        return -1;
    }
    int main()
    {
        char tmp[20];
        scanf("%d%d",&n,&l);
        scanf("%s",s);
        len=strlen(s);
        for(int i=0;s[i];i++) str[start+i]=s[len-1-i];
        int cnt=l,k;
        str[start+len]='';
        while(cnt--)
        {
            strncpy(tmp,str+start,13);
            if(len<13) tmp[len]='';
            else tmp[13]='';
            getnext(tmp);
            k=kmp(tmp);
            start--;
            len++;
            if(k==-1) str[start]='0';
            else str[start]=str[k];
        }
        for(int i=0;i<l;i++) ans[i]=str[start+l-1-i];
        ans[l]='';
        printf("%s",ans);
    }    
  • 相关阅读:
    bzoj 3035 二分答案+二分图最大匹配
    bzoj 1058 bst
    bzoj 1093 缩点+DP
    bzoj 1452 二维树状数组
    bzoj 1968 数学
    bzoj 1034 贪心
    牛客小白月赛12 I (tarjan求割边)
    Loj 103、10043 (KMP统计子串个数)
    poj 2356 (抽屉原理)
    hdu 1907 (尼姆博弈)
  • 原文地址:https://www.cnblogs.com/TheRoadToTheGold/p/6955699.html
Copyright © 2020-2023  润新知