• [解题报告]10110 Light, more light


    Light, more light

    The Problem

    There is man named "mabu" for switching on-off light in our University. He switches on-off the lights in a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns on. Another press will turn it off. To save power consumption (or may be he is mad or something else) he does a peculiar thing. If in a corridor there is `n' bulbs, he walks along the corridor back and forth `n' times and in i'th walk he toggles only the switches whose serial is divisable by i. He does not press any switch when coming back to his initial position. A i'th walk is defined as going down the corridor (while doing the peculiar thing) and coming back again.

    Now you have to determine what is the final condition of the last bulb. Is it on or off? 
     

    The Input

    The input will be an integer indicating the n'th bulb in a corridor. Which is less then or equals 2^32-1. A zero indicates the end of input. You should not process this input.

    The Output

    Output "yes" if the light is on otherwise "no" , in a single line.

    Sample Input

    3
    6241
    8191
    0

    Sample Output

    no
    yes
    no
    

    Sadi Khan 
    Suman Mahbub 
    01-04-2001

    理解题意以后就是水题了,判断是否完全平方数

    #include<stdio.h>
    #include<math.h>
    int main()
    {
     long long a,b,c;
     while(scanf("%lld",&a)!=EOF&&a)
     {
      b=sqrt(a);
      c=b*b;
      if(a==c) printf("yes\n");
      else printf("no\n");
     }
     return 0;
    }
  • 相关阅读:
    解读Android 12首个开发者预览版
    Pod创建私有库
    Flutter常用网站
    Flutter常用快捷键
    多个网络请求-并发执行、顺序执行
    小猫爬山问题---贪心算法失效,深度优先搜索优化
    网络基本概念备忘:MAC地址,端口,HTTP状态码
    常见图片文件格式简析
    pdf2xls
    评分卡模型
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2924694.html
Copyright © 2020-2023  润新知