• HDU 1018:Big Number (位数递推公式)


    Problem Description
    In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

    Input
    Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

    Output
    The output contains the number of digits in the factorial of the integers appearing in the input.

    Sample Input
    2
    10
    20

    Sample Output
    7
    19

    #include <cstdio>
    #include <string.h>
    #define N 1024
    #define MAXN 0x3f3f3f3f
    #include <map>
    #include <string>
    #include <cmath>
    #define pi acos(-1.0)
    #include <algorithm>
    #include <iostream>
    #include <iomanip>
    #include <set>
    using namespace std;
    int main()
    {
        int n,m,t;
        cin>>t;
        while(t--)
        {
            double sum=0;
            cin>>n;
            for(double i=1;i<=n;i++)
                sum+=log10(i);
            cout<<(int)sum+1<<endl;
    
        }
        return 0;
    }
    所遇皆星河
  • 相关阅读:
    mobile app 的总结
    ie和火狐javascript区别
    zepto源码注释
    ie6bug
    html5游戏网站
    jquery作者封装函数
    vue element 动态表格
    uniapp 对 系统的控制,全屏,系统虚拟键盘,手机导航,强制横屏
    环形图表记录
    清除所有的滚动条
  • 原文地址:https://www.cnblogs.com/Shallow-dream/p/11610481.html
Copyright © 2020-2023  润新知