• 1101-Trees on the Level


    描述

     

    Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics. This problem involves building and traversing binary trees. Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have fewer than 256 nodes. In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1. For example, a level order traversal of the tree

    is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

    In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.

    输入

    The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.
    All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

    输出

    For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed.

    样例输入

    (11,LL) (7,LLL) (8,R)

    (5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()

    (3,L) (4,R) ()

    样例输出

    5 4 8 11 13 4 7 2 1

    not complete

    #include <iostream>
    #include <queue>
    using namespace std;
    
    typedef struct tNode{
        int data;
        struct tNode *lchild, *rchild;
        tNode()
        {
            lchild = rchild = NULL;
            data = -9999999;
        }
    }*Node;
    bool flag;
    class Tree{
    private:
        Node root;
    public:
        Tree()
        {
            root = new tNode();
        }
        void insert(int data, char path[]); //????????????
        void print(int d); //??????
        void destory(); //????????????
        bool isBitTree(); //????????????????????????
    };
    
    void Tree::insert(int data, char path[])
    {
        int len = strlen(path);
        int i;
        Node cur = root;
        for(i = 0; i < len - 1; i++)
        {
            if(path[i] == 'L')
            {
                if(cur->lchild == NULL)
                    cur->lchild = new tNode();
                cur = cur->lchild;
            }else if(path[i] == 'R')
            {
                if(cur->rchild == NULL)
                    cur->rchild = new tNode();
                cur = cur->rchild;
            }
        }
        if(cur->data == -9999999)
            cur->data = data;
        else
            flag = false;
    }
    bool Tree::isBitTree()
    {
        queue<Node> q;
        q.push(root);
        while(!q.empty())
        {
            Node cur = q.front();
            q.pop();
            if(cur->data == -9999999)
                return false;
            if(cur->lchild)
                q.push(cur->lchild);
            if(cur->rchild)
                q.push(cur->rchild);
        }
        return true;
    }
    void Tree::destory()
    {
        queue<Node> q;
        q.push(root);
        while(!q.empty())
        {
            Node cur = q.front();
            q.pop();
            if(cur->lchild)
                q.push(cur->lchild);
            if(cur->rchild)
                q.push(cur->rchild);
            delete cur;
        }
        root = new tNode();
    }
    void Tree::print(int d)
    {
        queue<Node> q;
        q.push(root);
        int w = 0;
        while(!q.empty())
        {
            Node cur = q.front();
            q.pop();
            if(w == d - 1)
                cout<<cur->data;
            else
                cout<<cur->data<<" ";
            if(cur->lchild)
                q.push(cur->lchild);
            if(cur->rchild)
                q.push(cur->rchild);
            w++;
        }
        cout<<endl;
    }
    int main()
    {
        char snode[600];
        int data, d = 0;
        Tree t;
        flag = true;
        while(cin>>snode)
        {
            if(strcmp(snode, "()") == 0)
            {
                if(t.isBitTree() && flag)
                        t.print(d);
                else
                    cout<<"not complete"<<endl;
                t.destory();
                d = 0;
                flag = true;
                continue;
            }
            sscanf(snode + 1, "%d", &data);
            t.insert(data, strchr(snode, ',') + 1);
            d++;
        }
        return 0;
    }
    

      

  • 相关阅读:
    jdk9 特性
    jdk8 特性
    Eclipse中Spring插件的安装
    C++避免程序运行完后窗口一闪而过的方法
    完全二叉树节点个数
    Shell 编写倒着的*三角形
    Drools源于规则引擎
    Spring Data MongoDB 三:基本文档查询(Query、BasicQuery
    docker环境搭建
    MyBatis根据数组、集合查询
  • 原文地址:https://www.cnblogs.com/Rosanna/p/3436903.html
Copyright © 2020-2023  润新知