• Codeup 墓地 问题 A: Speech Patterns (25)


    题目描述

    People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

    Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

    输入

    Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return ' '. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

    输出

    For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

    Note that words are case insensitive.

    样例输入

    Can1: "Can a can can a can?  It can!"

    样例输出

    can 5
    #include<iostream>
    #include<map>
    #include<string>
    #include<algorithm>
    using namespace std;
    
    bool check(char ch)
    {
    	if (ch>='a'&&ch<='z') return true;
    	if (ch>='A'&&ch<='Z') return true;
    	if (ch>='0'&&ch<='9') return true;
    	return false;//合法字符 
    }
    
    int main()
    {
    	map<string,int>mp;
    	string s,ans;
    	string word;
    	getline(cin,s);
    	for (int i=0;i<s.length();i++)
    	{
    		
    		if (check(s[i]) ==true)
    		{
    			if (s[i]>='A'&&s[i]<='Z')
    			s[i]+=32;	
    			
    			word+=s[i];
    		}
    		if (check(s[i])==false || i==s.length()-1)
    		{
    			if (word.length()!=0)
    			mp[word]++;
    			
    			word = "";//清空 
    		}
    	}
    	int max=-1;
    	for (map<string,int>::iterator it=mp.begin();it!=mp.end();it++)
    	{
    		if (it->second>max)
    		{
    			max = it->second;
    			ans = it->first;
    		}
    	}
    	cout<<ans<<" "<<max<<endl;
    	return 0;
    }
    
    
    
    
    
    
  • 相关阅读:
    backtrace、backtrace_symbols、backtrace_symbols_fd-support for application self-debugging
    基于linux与busybox的reboot命令流程分析
    Ubuntu Linux 查看、编辑、比较二进制文件
    SecureCRT中的vim出现1H特殊字符
    单例模式和静态方法
    linux ls命令按时间显示文件
    Shallow Heap & Retained Heap
    jedis连接池的参数配置
    jvm参数设置和性能调优
    并发和并行的区别
  • 原文地址:https://www.cnblogs.com/Romantic-Chopin/p/12451427.html
Copyright © 2020-2023  润新知