• 1004. Counting Leaves (30)


    1004. Counting Leaves (30)

     
    A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

    Input

    Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

    ID K ID[1] ID[2] ... ID[K]
    
    where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

    Output

    For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

    The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

    Sample Input
    2 1
    01 1 02
    
    Sample Output
    0 1





    有关树的遍历的问题,用到了深搜的方法
    树的存放很有意思,map<int,vector<int> >; key为某个节点的ID,vector是他的孩子ID数组


    #include <iostream>
    #include <map>
    #include <vector>
    
    using namespace std;
    
    map<int,vector<int> > adjlist;
    int levelleaves[105]={0};
    
    void dfs(int node,int level){
        if(adjlist[node].empty()){
            levelleaves[level]++;
            return;
        }
        vector<int>:: iterator itea = adjlist[node].begin();
        for(;itea!=adjlist[node].end();itea++){
            dfs(*itea,level+1);
        }
    }
    
    
    int main()
    {
        int n,m;
        cin>>n>>m;
        int leaves = n-m;
        for(int i=0;i<m;i++){
            int id1,k, id2;
            cin>>id1>>k;
            for(int j=0;j<k;j++){
                cin>>id2;
                adjlist[id1].push_back(id2);
            }
        }
        dfs(1,0);
        int a=levelleaves[0];
        cout<<levelleaves[0];
        for(int i=1;a<leaves;i++){
            cout<<" "<<levelleaves[i];
            a=a+levelleaves[i];
        }
        return 0;
    }







  • 相关阅读:
    python 函数参数
    文件操作总结
    时间模块总结
    代码编程规范
    javascript 学习
    Spring-扫描注解原理,注解自动扫描原理分析
    String中的intern方法
    Zookeeper服务注册与发现原理浅析
    一篇文章了解RPC框架原理
    如何设计一个秒杀系统
  • 原文地址:https://www.cnblogs.com/Qmelbourne/p/6057337.html
Copyright © 2020-2023  润新知