• Farey Sequence (素筛欧拉函数/水)题解


    The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
    F2 = {1/2} 
    F3 = {1/3, 1/2, 2/3} 
    F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
    F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

    You task is to calculate the number of terms in the Farey sequence Fn.
    Input
    There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.
    Output
    For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 
    Sample Input
    2
    3
    4
    5
    0
    Sample Output
    1
    3
    5
    9


    思路:

    欧拉函数模板题了吧

    素筛法求得欧拉函数再加起来,记得用long long 

    代码:

    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    #include<cctype>
    #include<queue>
    #include<cmath>
    #include<string>
    #include<map>
    #include<stack> 
    #include<set>
    #include<vector>
    #include<iostream>
    #include<algorithm>
    #include<sstream>
    #define INF 0x3f3f3f3f
    #define ll long long
    const int N=1e6+5;
    const ll MOD=998244353;
    using namespace std;
    ll euler[N];
    void init(){
    	for(int i=0;i<N;i++) euler[i]=i;
    	for(ll i=2;i<N;i++){
    		if(euler[i]==i){
    			for(ll j=i;j<N;j+=i){
    				euler[j]=euler[j]/i*(i-1);
    			}
    		}
    	}
    	for(int i=3;i<N;i++) euler[i]+=euler[i-1];
    }
    int main(){
    	init();
    	ll n;
    	while(~scanf("%lld",&n) && n){
    		cout<<euler[n]<<endl;
    	}
    	return 0;
    }



  • 相关阅读:
    Out of hay
    P3028 [USACO10OCT]汽水机Soda Machine
    P3619 魔法
    P2847 [USACO16DEC]Moocast(gold)奶牛广播-金
    P2830 写程序
    c#DateTime与unix时间戳互相转换
    C# UdpClient使用
    udp单播,广播,多播实现(ReceiveFromAsync,SendToAsync)
    udp广播,单播,多播
    C#实现异步阻塞TCP(Send,Receive,Accept,Connect)
  • 原文地址:https://www.cnblogs.com/KirinSB/p/9409108.html
Copyright © 2020-2023  润新知