• PAT (Advanced Level) Practice 1137 Final Grading (25分)


    1.题目

    For a student taking the online course "Data Structures" on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G=(G​mid−term​​×40%+G​final​​×60%) if G​mid−term​​>G​final​​, or G​final​​ will be taken as the final grade G. Here G​mid−term​​ and G​final​​ are the student's scores of the mid-term and the final exams, respectively.

    The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.

    Then three blocks follow. The first block contains P online programming scores G​p​​'s; the second one contains M mid-term scores G​mid−term​​'s; and the last one contains N final exam scores G​final​​'s. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

    Output Specification:

    For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:

    StudentID G​p​​ G​mid−term​​ G​final​​ G

    If some score does not exist, output "−1" instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID's. It is guaranteed that the StudentID's are all distinct, and there is at least one qullified student.

    Sample Input:

    6 6 7
    01234 880
    a1903 199
    ydjh2 200
    wehu8 300
    dx86w 220
    missing 400
    ydhfu77 99
    wehu8 55
    ydjh2 98
    dx86w 88
    a1903 86
    01234 39
    ydhfu77 88
    a1903 66
    01234 58
    wehu8 84
    ydjh2 82
    missing 99
    dx86w 81
    

    Sample Output:

    missing 400 -1 99 99
    ydjh2 200 98 82 88
    dx86w 220 88 81 84
    wehu8 300 55 84 84

    2.代码

    #include<iostream>
    #include<string>
    #include<cstring>
    #include<map>
    #include<set>
    #include<algorithm>
    using namespace std;
    struct node
    {
    	string id;
    	int p;
    	int gm=-1;
    	int gf=-1;
    	int g;
    };
    struct cmp {     
    	bool operator()(const node &a, const node &b) {
    		if (a.g == b.g)
    			return a.id < b.id;
    		return a.g > b.g;
    	}
    };
    
    int main()
    {
    	int p, m, n;
    	map<string, node>list;
    	string name; int score;
    	cin >> p >> m >> n;
    	for (int i = 0; i < p; i++)
    	{
    		cin >> name >> score;
    			list[name].p = score;
    			list[name].id = name;
    	}
    	for (int i = 0; i < m; i++)
    	{
    		cin >> name >> score;
    		list[name].gm = score;
    		list[name].id = name;
    	}
    	for (int i = 0; i < n; i++)
    	{
    		cin >> name >> score;
    		list[name].gf = score;
    		list[name].id = name;
    	}
    	map<string, node>::iterator it;
    	for ( it = list.begin(); it != list.end(); it++) 
    	{
    		if (it->second.gm > it->second.gf)
    			it->second.g = int((double)it->second.gm*0.4 + (double)it->second.gf*0.6 + 0.5);
    		else it->second.g = it->second.gf;
    	}
    	multiset<node, cmp>out;
    	for (it = list.begin(); it != list.end(); it++)
    	{
    		if (it->second.g >= 60&&it->second.p>=200)
    			out.insert(it->second);
    	}
    	multiset<node, cmp>::iterator it2;
    	for (it2 = out.begin(); it2 != out.end(); it2++)
    	{
    		cout << it2->id << ' ' << it2->p << ' ' << it2->gm << ' ' << it2->gf <<' '<<it2->g<< endl;
    	}
    
    
    }
    
  • 相关阅读:
    [BZOJ2763] [JLOI2011] 飞行路线
    [BZOJ4033] [HAOI2015] 树上染色
    [BZOJ2565] 最长双回文串
    [luogu5048] [Ynoi2019模拟赛] Yuno loves sqrt technology III
    又犯了低级错误了
    Win10系统无法使用小米手机的远程管理功能
    DevExpress破解和消除弹出框问题
    重写导致的问题
    EXCEL统计不重复值的数量
    C#中Button.DialogResult属性
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788879.html
Copyright © 2020-2023  润新知