• PAT (Advanced Level) Practice 1071 Speech Patterns (25分)


    1.题目

    People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

    Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

    Input Specification:

    Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return  . The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

    Output Specification:

    For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

    Note that words are case insensitive.

    Sample Input:

    Can1: "Can a can can a can?  It can!"
    

    Sample Output:

    can 5

    2.代码

    #include<iostream>
    #include<string>
    #include<cstring>
    #include<unordered_map>
    #include<vector>
    #include<algorithm>
    using namespace std;
    int main()
    {
    	string list;
    	getline(cin, list);
    	unordered_map<string, int>amount;
    	string temp = "";
    	for (int i = 0; i < list.length(); i++)
    	{
    		if (isupper(list[i]))list[i] = tolower(list[i]);
    		if (temp != ""&&!isalpha(list[i]) && !isdigit(list[i])) { amount[temp]++; temp = ""; }
    		if (isalpha(list[i]) || isdigit(list[i]))temp += list[i];
    	}
    	amount[temp]++;
    	int max = -1;
    	string maxx;
    	for (auto it = amount.begin(); it != amount.end(); it++)
    	{
    		if (it->second > max) { max = it->second; maxx = it->first; }
    		if (it->second == max&&it->first>maxx) {  maxx = it->first; }
    	}
    	cout << maxx << " " << max;
    
    }
  • 相关阅读:
    Python基础——内置函数
    HHKB Mac快捷键使用
    解决EditText在ListView Item中,第一次点击无法获取焦点问题
    Android 设置Spinner默认显示文字
    IOS-静态Cell
    android-创建流式布局,并修改最后一行的最后一个view
    最简单的设置ExitText只能输入数字和字母的方法
    Android studio私人常用快捷键(持续更新)
    IOS-NSNotification(通知)
    Android书单(持续更新)
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788817.html
Copyright © 2020-2023  润新知