1.题目
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID
is a two-digit number representing a given non-leaf node, K
is the number of its children, followed by a sequence of two-digit ID
's of its children. For the sake of simplicity, let us fix the root ID to be 01
.
The input ends with N being 0. That case must NOT be processed.
Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01
is the root and 02
is its only child. Hence on the root 01
level, there is 0
leaf node; and on the next level, there is 1
leaf node. Then we should output 0 1
in a line.
Sample Input:
2 1
01 1 02
Sample Output:
0 1
2.题目分析
题目的数据结构是一棵普通的树型结构,使用DFS遍历,遇到叶子节点记录即可
3.代码
#include<iostream>
#include<vector>
using namespace std;
vector<int>list[110];
int n, m;
//int visited[110];
int deep[110];//对应数某层的叶子节点个数
int level=0;//树的层数
void DFS(int head, int times)
{
//visited[head] = 1;//这个基于vector数组的DFS不用visited维护,因为是按照顺序访问,彼此无交叉,毕竟是树而不是严格意义上的图
if (level < times)level = times;//记录树的总层数
if (list[head].size() == 0)deep[times]++;//是叶子节点就在相应位置的个数加一
else
for (int i = 0; i<list[head].size(); i++)
{
//if (visited[list[head][i]] == 0)
//{
times++;
DFS(list[head][i], times);
times--;
//}
}
}
int main()
{
int k, a, b;
scanf("%d", &n);
if (n == 0)return 0;
scanf("%d", &m);
for (int i = 1; i <= m; i++)
{
scanf("%d %d", &a, &k);
for (int j = 0; j<k; j++)
{
scanf("%d", &b);
list[a].push_back(b);
}
}
DFS(1, 0);
for (int i = 0; i<level+1; i++)
printf("%s%d", i == 0 ? "" : " ", deep[i]);
}