• POJ 2378 Tree Cutting【树形DP】


    Description

    After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses.

    Bessie, feeling vindictive, decided to sabotage Farmer John's network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ.

    Please help Bessie determine all of the barns that would be suitable to disconnect.

    Input

    * Line 1: A single integer, N. The barns are numbered 1..N.

    * Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.

    Output

    * Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE".

    Sample Input

    10
    1 2
    2 3
    3 4
    4 5
    6 7
    7 8
    8 9
    9 10
    3 8

    Sample Output

    3
    8

    Hint

    INPUT DETAILS:

    The set of connections in the input describes a "tree": it connects all the barns together and contains no cycles.

    OUTPUT DETAILS:

    If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).
     

    思路

    和前两道树形DP很神似,这道题很轻松的一个A了。

    题目大意:找若断开某个点,子树节点和的最大值不超过n/2就可以,找出这样的结点。

    源码

    #include<stdio.h>

    #include<string.h>

    #include<algorithm>

    #include<vector>

    using namespace std;

    int visit[10005], dp[10005], num[10005], map[10005];

    int n, t;

    vector<int>v[10005];

    void dfs(int tt)

    {

           int i, len=v[tt].size(),minn=0;

           visit[tt]=1;

           for(i=0; i<len; i++)

           {

                  if(!visit[v[tt][i]])

                  {

                         visit[v[tt][i]]=1;

                         dfs(v[tt][i]);

                  }

           }

           for(i=0; i<v[tt].size(); i++)

                  dp[tt]+=dp[v[tt][i]];

           dp[tt]++;

           int sum=0;

           for(i=0; i<v[tt].size(); i++)

           {

                  minn=max(minn, dp[v[tt][i]]);

                  sum+=dp[v[tt][i]];

           }

           minn=max(minn, n-sum-1);

           if(minn<=n/2)

                  num[t++]=tt;

    }

    int main()

    {

           int i, j, a, b;

           while(scanf("%d", &n)!=EOF)

           {

                  for(i=0; i<=n; i++)

                         v[i].clear();

                  for(i=0; i<n-1; i++)

                  {

                         scanf("%d%d", &a, &b);

                         v[a].push_back(b);

                      v[b].push_back(a);

                  }

                  memset(visit, 0, sizeof(visit));

                  memset(dp, 0, sizeof(dp));

                  memset(num, 0, sizeof(num));

                  memset(map, 0, sizeof(map));

                  t=0;

                  dfs(1);

                  sort(num, num+t);

                  for(i=0; i<t; i++)

                         printf("%d\n", num[i]);

           }

    }

  • 相关阅读:
    android 21 隐式意图启动系统预定义activity
    android 20 Intnet类重要的成员变量
    android 19 activity纵横屏切换的数据保存与恢复
    android 18 Bundle类
    android 17 activity生命周期
    Centos6.4建立本地yum源
    eclipse实现批量修改文件的编码方式
    [系统资源]/proc/meminfo和free输出解释
    监控WebLogic 8.x的解决方案(监控应用服务器系列文章)
    linux网络监控脚本
  • 原文地址:https://www.cnblogs.com/Hilda/p/2617254.html
Copyright © 2020-2023  润新知