• Doing Homework again 贪心


    Doing Homework again

    题目描述

     Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

    输入

     The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
    Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

    输出

     For each test case, you should output the smallest total reduced score, one line per test case.

    示例输入

    3
    3
    3 3 3
    10 5 1
    3
    1 3 1
    6 2 3
    7
    1 4 6 4 2 4 3
    3 2 1 7 6 5 4

    示例输出

    0
    3
    5

    提示

    #include<iostream>
    using namespace std;
    struct homework{
        int deadline, reduce;
    }a[1000], b;
    void quick_sort(homework s[], int l, int r){
        if(l < r){
            int i=l, j=r, x=s[l].deadline, y=s[l].reduce;
            b = s[l];
            while(i < j){
                while(i < j && (s[j].deadline > x || (s[j].deadline==x && s[j].reduce<y ) ) ) j--;
                if(i < j)  s[i++] = s[j];
                while(i < j && (s[i].deadline < x || (s[j].deadline==x && s[j].reduce>y )  ) ) i++;
                if(i < j)  s[j--] = s[i];
            }
            s[i] = b;
            quick_sort(s, l, i-1);
            quick_sort(s, i+1, r);
        }
    }
    int main(){
        int t;
        while(cin>>t) {
            while(t--){
                int n, i, Date = 1, score=0;
                cin>>n;
                for(i=0; i<n; i++)
                    cin>>a[i].deadline;
                for(i=0; i<n; i++)
                    cin>>a[i].reduce;
                quick_sort(a, 0, n-1);
                for(i=0; i<n; i++){
                    if(a[i].deadline >= Date) {
                        Date++;
                        continue;
                    }
                    int decline = a[i].reduce;
                    for(int j=0; j<i; j++)
                        if(a[j].reduce < decline )
                            decline = a[j].reduce;
                    score += decline;
                }
                cout<<score<<endl;
            }
        }
        return 0;
    }


  • 相关阅读:
    [Java学习] Java包装类、拆箱和装箱详解
    [Java学习] Java多态和动态绑定
    [Java学习] Java继承的概念与实现
    [Java学习] Java super关键字
    [Java代码] Java是自学好还是参加培训班好?
    [Java学习] Java字符串(String)
    [Java学习] Java方法重载
    [.NET源码] EF的增删改查
    C#面向服务WebService从入门到精通
    CoordinatorLayout-带图片伸缩工具栏
  • 原文地址:https://www.cnblogs.com/Genesis2018/p/8304807.html
Copyright © 2020-2023  润新知