• hdu 5311 Hidden String


    题目连接

    http://acm.hdu.edu.cn/showproblem.php?pid=5311  

    Hidden String

    Description

    Today is the 1st anniversary of BestCoder. Soda, the contest manager, gets a string s of length n. He wants to find three nonoverlapping substrings $s[l_1..r_1], s[l_2..r_2], s[l_3..r_3]$ that:

    1. $1 le l_1 le r_1 < l_2 le r_2 < l_3 le r_3 le n$

    2. The concatenation of $s[l_1..r_1], s[l_2..r_2], s[l_3..r_3]$ is "anniversary".

    Input


    There are multiple test cases. The first line of input contains an integer $T (1 leq T leq 100)$, indicating the number of test cases. For each test case:

    There's a line containing a string $s (1 leq |s| leq 100)$ consisting of lowercase English letters.

    Output

    For each test case, output "YES" (without the quotes) if Soda can find such thress substrings, otherwise output "NO" (without the quotes).

    Sample Input

    4
    annivddfdersewwefary
    nniversarya
    anniversarqy
    anniversayr

    Sample Output

    YES
    NO
    YES
    NO

    简单的字符串处理,暴力枚举即可。。

    #include<algorithm>
    #include<iostream>
    #include<cstdlib>
    #include<cstring>
    #include<cstdio>
    #include<vector>
    #include<map>
    using std::map;
    using std::endl;
    using std::find;
    using std::pair;
    using std::vector;
    using std::multimap;
    #define pb(e) push_back(e)
    #define sz(c) (int)(c).size()
    #define mp(a, b) make_pair(a, b)
    #define all(c) (c).begin(), (c).end()
    #define iter(c) __typeof((c).begin())
    #define cls(arr, val) memset(arr, val, sizeof(arr))
    #define cpresent(c, e) (find(all(c), (e)) != (c).end())
    #define rep(i, n) for(int i = 0; i < (int)n; i++)
    #define tr(c, i) for(iter(c) i = (c).begin(); i != (c).end(); ++i)
    const int N = 100001;
    const char* tar = "anniversary";
    char src[110];
    bool solve() {
        char s1[20], s2[20], s3[20];
        for(int i = 0; i < 10 ;i++) {
            for(int j = i + 1; j < 10; j++) {
                cls(s1, 0), cls(s2, 0), cls(s3, 0);
                strncpy(s1, tar, i + 1);
                strncpy(s2, tar + i + 1, j - i);
                strncpy(s3, tar + j + 1, 11 - j);
                char *p1 = strstr(src, s1);
                if(!p1) continue;
                char *p2 = strstr(p1 + strlen(s1), s2);
                if(!p2) continue;
                char *p3 = strstr(p2 + strlen(s2), s3);
                if(!p3) continue;
                if(p1 && p2 && p3) return true;
            }
        }
        return false;
    }
    int main() {
    #ifdef LOCAL
        freopen("in.txt", "r", stdin);
        freopen("out.txt", "w+", stdout);
    #endif
        int t;
        scanf("%d", &t);
        while(t--) {
            scanf("%s", src);
            puts(solve() ? "YES" : "NO");
        }
        return 0;
    }
  • 相关阅读:
    android studio 模拟器控制台发送短信和定位
    android获取超级权限
    android拦截获取别人发送过来的短信
    stackflow看到的获取手机联系人 contact 的代码
    surfaceview绘制矩形 drawRect
    Dialog自定义setView按钮点击没反应
    腾讯移动端性能测试利器PerfDog使用
    Mac下第一个Python程序:HelloWorld
    Mac 系统下安装 PyCharm 的实践
    如何用Chrome浏览器打开Axure原型的start.html文件
  • 原文地址:https://www.cnblogs.com/GadyPu/p/4796247.html
Copyright © 2020-2023  润新知