• hdoj1010 奇偶剪枝+DFS


    Tempter of the Bone

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 151082    Accepted Submission(s): 40265

    Problem Description

    The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
    The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

    Input

    The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
    'X': a block of wall, which the doggie cannot enter;
    'S': the start point of the doggie;
    'D': the Door; or
    '.': an empty block.
    The input is terminated with three 0's. This test case is not to be processed.

    Output

    For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

    Sample Input

    4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0

    Sample Output

    NO

    YES

    分析:这个题目用一般的搜索无法完成,因为题目要求在指定的时间内完成,所以只好一步一步来,用DFS解决。

    但是如果这样结果会超时,网上说是用一种奇偶剪枝的方法来间断搜索时间,下面是剪枝的简单理论,一看就懂:

                              把map看作

                                 0 1 0 1 0 1
                                 1 0 1 0 1 0
                                 0 1 0 1 0 1
                                 1 0 1 0 1 0
                                 0 1 0 1 0 1

                           从 0->1 需要奇数步

                           从 0->0 需要偶数步
                           那么设所在位置 (px,py) 与 目标位置 (ppx,ppy)

                           如果abs(px-ppx)+abs(py-ppy)为偶数,则说明 abs(x-y) 和 abs(dx-dy)的奇偶性相同,需要走偶数步

                           如果abs(x-y)+abs(dx-dy)为奇数,那么说明 abs(x-y) 和 abs(dx-dy)的奇偶性不同,需要走奇数步

                           理解为 abs(si-sj)+abs(di-dj) 的奇偶性就确定了所需要的步数的奇偶性!!

                           而 (t-setp)表示剩下还需要走的步数,由于题目要求要在 ti时 恰好到达,那么  (t-step) 与 abs(x-y)+abs(dx-dy) 的奇偶性必须相同

                           因此 t+abs(px-ppx)-abs(py-ppy) 必然为偶数!!!

    下面是AC代码:

    #include<iostream>
    #include<cstdlib>
    #include<string.h>
    using namespace std;
    
    int n,m,t;              // 行n列m时间t
    int flag;               //标记是否可以survive
    int dir[4][2]={1,0,-1,0,0,1,0,-1};       //用来表示下,上,右,左
    int visit[8][8];        //用来标识地图每一点是否被经过
    char map[8][8];         //记录地图每一点的属性
    int px,py,ppx,ppy;      //分别表示‘S’的坐标和‘D’的坐标
    
    void dfs(int x,int y,int count){
    	if(count>t)
    		return;
    	else if(map[x][y]=='D'){
    		if(count==t)
    			flag=1;
    		return;	
    	}
    	for(int i=0;i<4;i++){
    		int xx=x+dir[i][0];    //移动
    		int yy=y+dir[i][1];
    		if(map[xx][yy]!='X'&&xx>=0&&xx<n&&yy>=0&&yy<m)	
    			if(visit[xx][yy]==0){
    				visit[xx][yy]=1;
    				dfs(xx,yy,count+1);
    				if(flag)
    					return;
    				visit[xx][yy]=0;
    			}
    	}
    }
    
    int main(){
    	while(cin>>n>>m>>t&&(m+n+t)){
    		flag=0;
    		for(int i=0;i<n;i++){
    			cin>>map[i];
    			for(int j=0;j<m;j++){
    				if(map[i][j]=='S'){
    					px=i;
    					py=j;
    				}
    				if(map[i][j]=='D'){
    					ppx=i;
    					ppy=j;
    				}
    			}
    		}
    		if((abs(px-ppx)+abs(py-ppy)+t)&1){     //奇偶剪枝
    			cout<<"NO"<<endl;
    			continue;
    		}
    		memset(visit,0,sizeof(visit));
    		visit[px][py]=1;           //将‘S’处标记为已经过
    		dfs(px,py,0);
    		if(flag) cout<<"YES"<<endl;
    		else cout<<"NO"<<endl;
    	}
    	return 0;
    }

     体会:学习了奇偶剪枝技巧和DFS算法。

  • 相关阅读:
    修改项目名称
    Servlet中request、response、ServletContext 及其常用方法
    Servlet生命周期、常用提交方式、中文乱码问题、重定向和请求转发
    JavaScript基础(三) 事件
    JavaScript基础(二) DOM
    JavaScript基础(一)
    css基础:样式之定位、样式之隐藏、二级菜单、多个列表转表格、图片精灵技术
    css基础:表格样式、一级菜单、BFC浮动影响
    css基础及其实例:常用选择器、颜色五中写法、字体样式、自定义字体、盒模型及其样式设置
    HTML元素标签及表单元素详解
  • 原文地址:https://www.cnblogs.com/FrankChen831X/p/10326087.html
Copyright © 2020-2023  润新知