• POJ1523 SPF


    POJ1523 SPF
    Time Limit: 1000MS Memory Limit: 10000K
    Total Submissions: 2869 Accepted: 1284

    Description

    Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 

    Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 

    Input

    The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

    Output

    For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 

    The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

    Sample Input

    1 2
    5 4
    3 1
    3 2
    3 4
    3 5
    0
    
    1 2
    2 3
    3 4
    4 5
    5 1
    0
    
    1 2
    2 3
    3 4
    4 6
    6 3
    2 5
    5 1
    0
    
    0

    Sample Output

    Network #1
      SPF node 3 leaves 2 subnets
    
    Network #2
      No SPF nodes
    
    Network #3
      SPF node 2 leaves 2 subnets
      SPF node 3 leaves 2 subnets
    *****************************************************************
    题目大意:给定一个图,求这个图的割点,以及把该割点去掉以后的图有多少过连通分量。
    求割点,但是不太会,写的比较差。先用tarjan算法找割点,再用dfs找出这个割点把图分成多少块。
    #include <stdio.h>
    #include <string.h>
    #include <stack>
    #include <vector>
    #include <algorithm>
    #define MIN(a,b) ((a)<(b)?(a):(b))
    using namespace std;
    
    vector<int>gra[1005],ans;
    int dfn[1005],low[1005],now,id,sum[1005];
    
    void tarjan(int s,int p)
    {
        dfn[s]=low[s]=++now;
        int son=0;
        for(int i=0;i<gra[s].size();i++)
            if(!dfn[gra[s][i]])
            {
                tarjan(gra[s][i],s);
                low[s]=MIN(low[s],low[gra[s][i]]);
                if(low[gra[s][i]]>=dfn[s])
                    sum[s]++;
                son++;
            }
            else
                if(gra[s][i]!=p)
                    low[s]=MIN(low[s],dfn[gra[s][i]]);
        if(p==0)
        {
            if(son>=2)
                ans.push_back(s),sum[s]=son;
        }
        else
            if(sum[s]>=1)
                ans.push_back(s),sum[s]++;
    }
    
    int main()
    {
        for(int ncase=1;;ncase++)
        {
            int s,t;
            scanf("%d",&s);
            if(!s)break;
            for(int i=0;i<=1000;i++)
                gra[i].clear();
            ans.clear();
            memset(dfn,0,sizeof(dfn));
            memset(low,0,sizeof(low));
            memset(sum,0,sizeof(sum));
            now=0;
            while(1)
            {
                scanf("%d",&t);
                gra[s].push_back(t);
                gra[t].push_back(s);
                scanf("%d",&s);
                if(!s)break;
            }
            for(int i=1;i<=1000;i++)
                if(dfn[i]==0&&gra[i].size()!=0)
                    tarjan(i,0);
            sort(&ans[0],&ans[0]+ans.size());
            printf("Network #%d\n",ncase);
            for(int i=0;i<ans.size();i++)
                printf("  SPF node %d leaves %d subnets\n",ans[i],sum[ans[i]]);
            if(ans.size()==0)
                puts("  No SPF nodes");
            puts("");
        }
    }
    

      

  • 相关阅读:
    Java 读取txt文件,读取结果保存到数据库
    Java 读取大文件方法
    利用File类过滤器列出目录下的指定目录或文件
    Java 读取指定目录下的文件名和目录名
    利用js日期控件重构WEB功能
    简洁js日历控件的使用
    Tomcat中配置URIEncoding="UTF-8"来处理中文的方法
    Java MVC 增删改查 实例
    严重:The web application [web01] appears to have started a thread named ...
    警告: [SetPropertiesRule]{Server/Service/Engine/Host/Context} 解决方法
  • 原文地址:https://www.cnblogs.com/Fatedayt/p/2181644.html
Copyright © 2020-2023  润新知