• PAT 甲级 1015 Reversible Primes(20)


    1015 Reversible Primes(20 分)

    reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

    Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

    Input Specification:

    The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

    Output Specification:

    For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

    Sample Input:

    73 10
    23 2
    23 10
    -2
    

    Sample Output:

    Yes
    Yes
    No

    解题流程:

           对于每行输入的两个数据N

                 将N转化为D进制的数(字符串),各位数字(字符)倒叙

                 倒叙后按进制D还原为10进制,得到数字rN

                 判断条件:如果rNN都为素数,输出Yes,否则输出No

                 结束条件:N为负数

    #include<iostream>
    #include<string>
    #include<cmath>
    using namespace std;
    int judge(int a) {      //判断素数
    	if (a == 1)
    		return 0;
    	for (int i = 2; i <= sqrt(a); i++)
    		if (a%i == 0)
    			return 0;
    	return 1;
    }
    int trans(int N, int D) {      //数字转化为D进制--逆转--还原10进制
    	string str;
    	for (; N != 0; N /= D)
    		str += to_string(N%D);
    	return stoi(str, 0, D);
    }
    int main() {
    	int N, D;
    	while (1) {
    		cin >> N >> D;     //N 、D可分开判断N
    		if (N < 0)	break;
    		if (judge(N) && judge(trans(N, D)))
    			cout << "Yes" << endl;
    		else
    			cout << "No" << endl;
    	}
    	return 0;
    }
  • 相关阅读:
    图论小测
    有关连通性
    差分约束
    php中代码执行&&命令执行函数【转载】
    Boss直聘的一个csrf与url跳转漏洞(已经修复)
    Immunity Canvas初体验加操作指南
    SSRF复习版本
    XXE漏洞复习版本
    信息收集汇总
    web前端逆向初体验
  • 原文地址:https://www.cnblogs.com/F-itachi/p/9974363.html
Copyright © 2020-2023  润新知