To complete this configuration example, your OSPF configuration must meet the following criteria:
-
Router ID (RIfD) based on lo0 address.
-
lo0 address must be reachable via OSPF.
-
Loopback addresses from backbone routers appear as summaries in area 1.
-
The link between r3 and T1 must appear in area 0 as an intra-area route. Ensure that no adjacencies can be established on this interface.
configure:
lab@olive-r3# show
version 6.4R3.4;
system {
host-name olive-r3;
root-authentication {
encrypted-password "$1$9HaTvZNq$B2vePIhHtepgp8fEnC6rJ0"; ## SECRET-DATA
}
login {
user lab {
uid 2008;
class super-user;
authentication {
encrypted-password "$1$saXjchrx$OSVYMP3IPIDXsB2Tzs1B1."; ## SECRET-DATA
}
}
}
services {
telnet;
}
}
logical-routers {
r3 {
interfaces {
fxp1 {
unit 56 {
vlan-id 56;
family inet {
address 10.0.2.5/30;
}
}
}
fxp2 {
unit 12 {
vlan-id 12;
family inet {
address 10.0.2.2/30;
}
}
unit 13 {
vlan-id 13;
family inet {
address 172.16.0.13/30;
}
}
}
lo0 {
unit 3 {
family inet {
address 10.0.3.3/32;
}
}
}
}
protocols {
ospf {
area 0.0.0.0 {
interface lo0.3 {
passive;
}
interface fxp1.56;
interface fxp2.12;
interface fxp2.13 {
passive;
}
}
}
}
}
r4 {
interfaces {
fxp2 {
unit 56 {
vlan-id 56;
family inet {
address 10.0.2.6/30;
}
}
unit 109 {
vlan-id 109;
family inet {
address 10.0.2.10/30;
}
}
}
lo0 {
unit 4 {
family inet {
address 10.0.3.4/32;
}
}
}
}
protocols {
ospf {
area 0.0.0.0 {
interface lo0.4 {
passive;
}
interface fxp2.109;
interface fxp2.56;
}
}
}
}
r5 {
interfaces {
fxp1 {
unit 12 {
vlan-id 12;
family inet {
address 10.0.2.1/30;
}
}
unit 65 {
vlan-id 65;
family inet {
address 10.0.8.6/30;
}
}
unit 109 {
vlan-id 109;
family inet {
address 10.0.2.9/30;
}
}
unit 910 {
vlan-id 910;
family inet {
address 10.0.8.9/30;
}
}
}
lo0 {
unit 5 {
family inet {
address 10.0.3.5/32;
}
}
}
}
protocols {
ospf {
area 0.0.0.0 {
interface lo0.5 {
passive;
}
interface fxp1.12;
interface fxp1.109;
}
area 0.0.0.1 {
authentication-type simple;
interface fxp1.65;
interface fxp1.910 {
authentication {
simple-password "$9$CJdepOILXNbw2jHCp"; ## SECRET-DATA
}
}
}
}
}
}
r6 {
interfaces {
fxp2 {
unit 21 {
vlan-id 21;
family inet {
address 10.0.8.1/30;
}
}
unit 65 {
vlan-id 65;
family inet {
address 10.0.8.5/30;
}
}
}
lo0 {
unit 6 {
family inet {
address 10.0.9.6/32;
}
}
}
}
protocols {
ospf {
area 0.0.0.1 {
interface fxp2.21;
interface fxp2.65;
interface lo0.6 {
passive;
}
}
}
}
}
r7 {
interfaces {
fxp1 {
unit 21 {
vlan-id 21;
family inet {
address 10.0.8.2/30;
}
}
}
fxp2 {
unit 910 {
vlan-id 910;
family inet {
address 10.0.8.10/30;
}
}
}
lo0 {
unit 7 {
family inet {
address 10.0.9.7/32;
}
}
}
}
protocols {
ospf {
area 0.0.0.1 {
authentication-type simple;
interface fxp2.910 {
authentication {
simple-password "$9$vZz8x-UDHmPTApv8"; ## SECRET-DATA
}
}
interface fxp1.21;
interface lo0.7 {
passive;
}
}
}
}
}
t1 {
interfaces {
fxp1 {
unit 13 {
vlan-id 13;
family inet {
address 172.16.0.14/30;
}
}
}
}
}
}
interfaces {
fxp0 {
unit 0 {
family inet {
address 192.168.4.236/24;
}
}
}
fxp1 {
vlan-tagging;
}
fxp2 {
vlan-tagging;
}
}
routing-options {
static {
route 0.0.0.0/0 next-hop 192.168.4.3;
}
}
Verify OSPF
[edit]
lab@olive-r3# run show ospf interface logical-router r5
Interface State Area DR ID BDR ID Nbrs
fxp1.109 BDR 0.0.0.0 10.0.3.4 10.0.3.5 1
fxp1.12 DR 0.0.0.0 10.0.3.5 10.0.3.3 1
lo0.5 DRother 0.0.0.0 0.0.0.0 0.0.0.0 0
fxp1.65 DR 0.0.0.1 10.0.3.5 10.0.9.6 1
fxp1.910 BDR 0.0.0.1 10.0.9.7 10.0.3.5 1
[edit]
lab@olive-r3# run show ospf neighbor logical-router r5
Address Interface State ID Pri Dead
10.0.2.10 fxp1.109 Full 10.0.3.4 128 30
10.0.2.2 fxp1.12 Full 10.0.3.3 128 38
10.0.8.5 fxp1.65 Full 10.0.9.6 128 33
10.0.8.10 fxp1.910 Full 10.0.9.7 128 33
lab@olive-r3# run show ospf database logical-router r5
OSPF link state database, area 0.0.0.0
Type ID Adv Rtr Seq Age Opt Cksum Len
Router 10.0.3.3 10.0.3.3 0x80000006 844 0x2 0x7660 72
Router 10.0.3.4 10.0.3.4 0x8000000c 844 0x2 0x345e 60
Router *10.0.3.5 10.0.3.5 0x8000000a 389 0x2 0x9c11 60
Network *10.0.2.1 10.0.3.5 0x80000002 759 0x2 0x908a 32
Network 10.0.2.6 10.0.3.4 0x80000002 278 0x2 0x5abd 32
Network 10.0.2.10 10.0.3.4 0x80000002 578 0x2 0x4ec3 32
Summary *10.0.8.0 10.0.3.5 0x80000004 837 0x2 0xfe38 28
Summary *10.0.8.4 10.0.3.5 0x80000005 843 0x2 0xca68 28
Summary *10.0.8.8 10.0.3.5 0x80000007 837 0x2 0x9e8e 28
Summary *10.0.9.6 10.0.3.5 0x80000003 843 0x2 0xc16d 28
Summary *10.0.9.7 10.0.3.5 0x80000003 837 0x2 0xb776 28
OSPF link state database, area 0.0.0.1
Type ID Adv Rtr Seq Age Opt Cksum Len
Router *10.0.3.5 10.0.3.5 0x8000000a 843 0x2 0xa20b 48
Router 10.0.9.6 10.0.9.6 0x80000006 844 0x2 0x6516 60
Router 10.0.9.7 10.0.9.7 0x80000004 840 0x2 0xc1b7 60
Network 10.0.8.1 10.0.9.6 0x80000001 885 0x2 0xe617 32
Network *10.0.8.6 10.0.3.5 0x80000002 506 0x2 0x9472 32
Network 10.0.8.10 10.0.9.7 0x80000002 840 0x2 0x24d5 32
Summary *10.0.2.0 10.0.3.5 0x80000007 209 0x2 0x310a 28
Summary *10.0.2.4 10.0.3.5 0x80000008 89 0x2 0x1124 28
Summary *10.0.2.8 10.0.3.5 0x80000006 843 0x2 0xe251 28
Summary *10.0.3.3 10.0.3.5 0x80000004 843 0x2 0x2017 28
Summary *10.0.3.4 10.0.3.5 0x80000005 843 0x2 0x1421 28
Summary *10.0.3.5 10.0.3.5 0x80000005 843 0x2 0xff35 28
Summary *172.16.0.12 10.0.3.5 0x80000004 843 0x2 0x3641 28
[edit]
lab@olive-r3# run show ospf database logical-router r6
OSPF link state database, area 0.0.0.1
Type ID Adv Rtr Seq Age Opt Cksum Len
Router 10.0.3.5 10.0.3.5 0x8000000a 951 0x2 0xa20b 48
Router *10.0.9.6 10.0.9.6 0x80000006 950 0x2 0x6516 60
Router 10.0.9.7 10.0.9.7 0x80000004 948 0x2 0xc1b7 60
Network *10.0.8.1 10.0.9.6 0x80000001 991 0x2 0xe617 32
Network 10.0.8.6 10.0.3.5 0x80000002 614 0x2 0x9472 32
Network 10.0.8.10 10.0.9.7 0x80000002 947 0x2 0x24d5 32
Summary 10.0.2.0 10.0.3.5 0x80000007 317 0x2 0x310a 28
Summary 10.0.2.4 10.0.3.5 0x80000008 197 0x2 0x1124 28
Summary 10.0.2.8 10.0.3.5 0x80000007 17 0x2 0xe052 28
Summary 10.0.3.3 10.0.3.5 0x80000004 951 0x2 0x2017 28
Summary 10.0.3.4 10.0.3.5 0x80000005 951 0x2 0x1421 28
Summary 10.0.3.5 10.0.3.5 0x80000005 951 0x2 0xff35 28
Summary 172.16.0.12 10.0.3.5 0x80000004 951 0x2 0x3641 28