• B


    Farmer John has received a noise complaint from his neighbor, Farmer Bob, stating that his cows are making too much noise.

    FJ's N cows (1 <= N <= 10,000) all graze at various locations on a long one-dimensional pasture. The cows are very chatty animals. Every pair of cows simultaneously carries on a conversation (so every cow is simultaneously MOOing at all of the N-1 other cows). When cow i MOOs at cow j, the volume of this MOO must be equal to the distance between i and j, in order for j to be able to hear the MOO at all. Please help FJ compute the total volume of sound being generated by all N*(N-1) simultaneous MOOing sessions.

    Input

    * Line 1: N

    * Lines 2..N+1: The location of each cow (in the range 0..1,000,000,000).

    Output

    There are five cows at locations 1, 5, 3, 2, and 4.

    Sample Input

    5
    1
    5
    3
    2
    4

    Sample Output

    40

    Hint

    INPUT DETAILS:

    There are five cows at locations 1, 5, 3, 2, and 4.

    OUTPUT DETAILS:

    Cow at 1 contributes 1+2+3+4=10, cow at 5 contributes 4+3+2+1=10, cow at 3 contributes 2+1+1+2=6, cow at 2 contributes 1+1+2+3=7, and cow at 4 contributes 3+2+1+1=7. The total volume is (10+10+6+7+7) = 40.
     
    贴两种方法:
    第一种:
    就是找规律,这个特别难想。
    先对a数组进行排序,然后求出相邻的差分
    之后就根据n头牛,和第i头牛直接差分用的次数找到规律,直接计算。
     
    第二种,比较简单
    就是也要排序
    然后第i头牛的音量就是第i-1头牛再加上(i-1-1)*d  (d是i和i-1的距离) 再减去 (n-i)*d
    其实每头之间牛音量的不同就在于他们的距离,所以对他们的距离进行处理即可。
     
    #include <stdio.h>
    #include <stdlib.h>
    #include <string.h>
    #include <algorithm>
    #include <iostream>
    using namespace std;
    typedef long long ll;//要找规律!!!
    ll a[11000];
    int main()
    {
        int n;
        cin>>n;
        for(int i=0;i<n;i++) scanf("%I64d",&a[i]);
        sort(a,a+n);
        ll sum=0;
        for(int i=1;i<n;i++)
        {
            sum+=(a[i]-a[i-1])*i*(n-i)*2;
        }
        cout<<sum<<endl;
        return 0;
    }
    

      

    #include <stdio.h>
    #include <stdlib.h>
    #include <string.h>
    #include <algorithm>
    #include <iostream>
    using namespace std;
    typedef long long ll;
    ll a[11000],b[11000];
    int main()
    {
        int n;
        cin>>n;
        for(int i=1;i<=n;i++) scanf("%I64d",&a[i]);
        sort(a+1,a+n+1);
        for(int i=2;i<=n;i++)
        {
            b[1]+=abs(a[i]-a[1]);
        }
        ll sum=b[1];
        for(int i=2;i<=n;i++)
        {
            ll d=a[i]-a[i-1];
            b[i]=b[i-1]+(i-1-1)*d-(n-i)*d;
            sum+=b[i];
        }
        cout<<sum<<endl;
        return 0;
    }

      

     
     
  • 相关阅读:
    关于跨域名访问,反向代理系列话题集锦
    中国B2C电子商务最新发展状况调查分析(转)
    顶部导航条(Top Navigation Bar)_Yahoo_Pattern(翻译)
    google,百度,yahoo,msn,ASK网址登录和网站地图提交地址
    如何安装PE到硬盘(包括移动硬盘)分区
    ASP.NET SQL 注入免费解决方案
    O2O循环圈
    B2C暴利行业之保健品行业
    在SQLserver2005中如何对运行慢的查询进行分析?
    互联网产品设计之需求管理
  • 原文地址:https://www.cnblogs.com/EchoZQN/p/10357570.html
Copyright © 2020-2023  润新知