• Oil Deposits HDU


    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

    InputThe input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
    OutputFor each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 
    Sample Input

    1 1
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5 
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0 

    Sample Output

    0
    1
    2
    2
    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    #include<cstring>
    #include<queue>
    #include<math.h>
    #include<memory.h>
    using namespace std;
    bool vis[105][105];
    char m[105][105];
    int dir[8][2] = { {0,1},{0,-1},{1,0},{-1,0},{1,1},{1,-1},{-1,1},{-1,-1} };
    int l, r;
    int num;
    void dfs(int i,int j) {
        int x, y;
        for (int k = 0; k < 8; k++) {
            x = i + dir[k][0];
            y = j + dir[k][1];
            if (x < 0 || x >= l || y < 0 || y >= r)continue;
            if (m[x][y] == '@' && !vis[x][y]) {
                vis[x][y] = true;
                dfs(x, y);
            }
        }
        return;
    }
    
    int main() {
        while (cin >> l >> r) {
            if (l == 0 && r == 0)break;
            memset(vis, 0, sizeof vis);
            num = 0;
            for (int i = 0; i < l; i++) {
                for (int j = 0; j < r; j++) {
                    cin >> m[i][j];
                }
            }
            for (int i = 0; i < l; i++) {
                for (int j = 0; j < r; j++) {
                    if (!vis[i][j]&&m[i][j]=='@') {
                        vis[i][j] = true;
                        dfs(i, j);
                        num++;
                    }
                }
            }
            cout << num << endl;
        }
    }
  • 相关阅读:
    ASP.NET配置文件Web.config 详细解释
    Firefox 3.6最新功能:网页可根据设备方位调整角度
    ascx + wrapper page + jQuery的Ajax解决方案
    C#中常用的文件操作方法
    Excel鲜为人知的35招秘技
    NHibernate.Search 基于Lucene.NET的全文索引
    Firefox和IE之间7个JavaScript的差异
    .net2.0使用json的知识,要点,问题和解决方案
    服务器响应HTTP的类型ContentType大全
    欢迎Clonezilla,再见Symantec Ghost
  • 原文地址:https://www.cnblogs.com/CuteAbacus/p/9492203.html
Copyright © 2020-2023  润新知