The Triangle
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 32637 | Accepted: 19322 |
Description
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
57
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30Source
IOI 1994
#include <iostream>
#include <cstring>
using namespace std;
int a[111][111];
int dp[111][111];
int main()
{
int n;
cin>>n;
for(int i=1;i<=n;i++)
for(int j=1;j<=i;j++)
cin>>a[j];
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
dp[n]=a[n];
for(int i=n-1;i>=1;i--)
for(int j=1;j<=i;j++)
dp[j]=max(dp[i+1][j],dp[i+1][j+1])+a[j];
cout<<dp[1][1]<<endl;
return 0;
}