• HDOJ 2870 Largest Submatrix


    逐层的找最大面积。

    Largest Submatrix

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 967    Accepted Submission(s): 467


    Problem Description
    Now here is a matrix with letter 'a','b','c','w','x','y','z' and you can change 'w' to 'a' or 'b', change 'x' to 'b' or 'c', change 'y' to 'a' or 'c', and change 'z' to 'a', 'b' or 'c'. After you changed it, what's the largest submatrix with the same letters you can make?
     

    Input
    The input contains multiple test cases. Each test case begins with m and n (1 ≤ m, n ≤ 1000) on line. Then come the elements of a matrix in row-major order on m lines each with n letters. The input ends once EOF is met.
     

    Output
    For each test case, output one line containing the number of elements of the largest submatrix of all same letters.
     

    Sample Input
    2 4
    abcw
    wxyz
     

    Sample Output
    3
     

    Source
     

    Recommend
    gaojie
     

    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    const int N=1005;

    char a[N][N];
    int high[N];
    int C,R;

    bool isH(char stc,char c)
    {
        if(stc=='a')
            return c=='a'||c=='w'||c=='y'||c=='z';
        if(stc=='b')
            return c=='b'||c=='w'||c=='x'||c=='z';
        if(stc=='c')
            return c=='c'||c=='x'||c=='y'||c=='z';
        return false;
    }

    int main()
    {
        while(scanf("%d%d",&R,&C)!=EOF)
        {
            for(int i=0;i<R;i++)
              scanf("%s",a);

        int ans=-1;

        for(char stc='a';stc<='c';stc++)
        {
            memset(high,0,sizeof(high));

            for(int i=0;i<R;i++)
            {
                for(int j=0;j<C;j++)
                {
                    if(isH(stc,a[j]))
                        high[j]++;
                    else
                        high[j]=0;
                }

                for(int j=0;j<C;j++)
                {
                    int cnt=1;
                    if(high[j]==0) continue;
                    for(int k=j-1;k>=0&&high[k]>=high[j];k--)
                        cnt++;
                    for(int k=j+1;k<C&&high[k]>=high[j];k++)
                        cnt++;
                    ans=max(ans,high[j]*cnt);
                }
            }
        }

        printf("%d\n",ans);

        }

        return 0;
    }

  • 相关阅读:
    【洛谷P4319】 变化的道路 线段树分治+LCT
    【洛谷P4585】 [FJOI2015]火星商店问题 线段树分治+可持久化trie
    Spring Framework Part4 self-summeries-a simplified MVC framework
    Spring Framework Part3 IoC and Dynamic Proxy
    Spring Framework Part2 IOC
    Big Data(一)分治思想
    排序算法(6.15)
    KMP算法(6.14)
    数据结构之查找(图片来源,老师PPT)
    MongoDB的基本操作
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351046.html
Copyright © 2020-2023  润新知