• POJ 3667 Hotel





    Hotel
    Time Limit: 3000MSMemory Limit: 65536K
    Total Submissions: 9630Accepted: 4126

    Description

    The cows are journeying north to Thunder Bay in Canada to gain cultural enrichment and enjoy a vacation on the sunny shores of Lake Superior. Bessie, ever the competent travel agent, has named the Bullmoose Hotel on famed Cumberland Street as their vacation residence. This immense hotel has N (1 ≤ N ≤ 50,000) rooms all located on the same side of an extremely long hallway (all the better to see the lake, of course).

    The cows and other visitors arrive in groups of size Di (1 ≤ Di ≤ N) and approach the front desk to check in. Each group i requests a set of Di contiguous rooms from Canmuu, the moose staffing the counter. He assigns them some set of consecutive room numbers r..r+Di-1 if they are available or, if no contiguous set of rooms is available, politely suggests alternate lodging. Canmuu always chooses the value of r to be the smallest possible.

    Visitors also depart the hotel from groups of contiguous rooms. Checkout i has the parameters Xi and Di which specify the vacating of rooms Xi ..Xi +Di-1 (1 ≤ Xi ≤ N-Di+1). Some (or all) of those rooms might be empty before the checkout.

    Your job is to assist Canmuu by processing M (1 ≤ M < 50,000) checkin/checkout requests. The hotel is initially unoccupied.

    Input

    * Line 1: Two space-separated integers: N and M
    * Lines 2..M+1: Line i+1 contains request expressed as one of two possible formats: (a) Two space separated integers representing a check-in request: 1 and D(b) Three space-separated integers representing a check-out: 2, Xi, andDi

    Output

    * Lines 1.....: For each check-in request, output a single line with a single integer r, the first room in the contiguous sequence of rooms to be occupied. If the request cannot be satisfied, output 0.

    Sample Input

    10 6
    1 3
    1 3
    1 3
    1 3
    2 5 5
    1 6

    Sample Output

    1
    4
    7
    0
    5

    Source

    USACO 2008 February Gold 

    线段树,区间合并。。。。

    tip :
    线段树每个节点 记录 3个参数 :
    lSpace :左端开始的空余量
    rSpace :右端开始的空余量
    mSpace : 最大空余量(可能在中间)

    如 
    ~~~~**~~~~~**~~
    lSpace = 4
    rSpace = 2
    mSpace = 5



    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1

    const int MAXN=111111;
    int msum[MAXN<<2],lsum[MAXN<<2],rsum[MAXN<<2],col[MAXN<<2];

    void pushDOWN(int rt,int m)
    {
        if(col[rt]!=-1)
        {
            msum[rt<<1]=lsum[rt<<1]=rsum[rt<<1]=  col[rt]?0:m-(m>>1);
            msum[rt<<1|1]=lsum[rt<<1|1]=rsum[rt<<1|1]= col[rt]?0:m>>1;
            col[rt<<1]=col[rt<<1|1]=col[rt];
            col[rt]=-1;
        }
    }

    void pushUP(int rt,int m)
    {
        lsum[rt]=lsum[rt<<1];
        rsum[rt]=rsum[rt<<1|1];
        if(lsum[rt<<1]==(m-(m>>1))) lsum[rt]+=lsum[rt<<1|1];
        if(rsum[rt<<1|1]==(m>>1)) rsum[rt]+=rsum[rt<<1];
        msum[rt]=max(lsum[rt<<1|1]+rsum[rt<<1],max(msum[rt<<1],msum[rt<<1|1]));
    }

    void build(int l,int r,int rt)
    {
        lsum[rt]=rsum[rt]=msum[rt]=r-l+1;
        col[rt]=-1;
        if(l==r) return ;
        int m=(l+r)>>1;
        build(lson);  build(rson);
    }

    void update(int L,int R,int c,int l,int r,int rt)
    {
        if(L<=l&&r<=R)
        {
            msum[rt]=lsum[rt]=rsum[rt]=c?0:r-l+1;
            col[rt]=c;
            return ;
        }
        pushDOWN(rt,r-l+1);
        int m=(l+r)>>1;
        if(L<=m) update(L,R,c,lson);
        if(R>m) update(L,R,c,rson);
        pushUP(rt,r-l+1);
    }

    int query(int w,int l,int r ,int rt)
    {
        if(l==r) return r;
        pushDOWN(rt,r-l+1);
        int m=(l+r)>>1;
        if(msum[rt<<1]>=w) return query(w,lson);
        else if(rsum[rt<<1]+lsum[rt<<1|1]>=w) return m-rsum[rt<<1]+1;
        else return query(w,rson);
    }

    int main()
    {
        int n,m,a,b,c;
    while(cin>>n>>m)
    {
        build(1,n,1);
        while(m--)
        {
            cin>>a;
            if(a==1)
            {
                cin>>b;
                if(msum[1]<b) puts("0");
                else
                {
                    int p=query(b,1,n,1);
                    cout<<p<<endl;
                    update(p,p+b-1,1,1,n,1);
                }
            }
            else if(a==2)
            {
                cin>>b>>c;
                update(b,b+c-1,0,1,n,1);
            }
        }
    }

        return 0;
    }
    * This source code was highlighted by YcdoiT. ( style: Codeblocks )

  • 相关阅读:
    批量改文件名小工具
    整理一下在 npmjs.com 上面发布资源包踩过的坑
    告别Vuex,发挥compositionAPI的优势,打造Vue3专用的轻量级状态
    vue3 专用 indexedDB 封装库,基于Promise告别回调地狱
    C++ 学习笔记(三):介绍几个在线编译器【转】
    【Linux】一篇文章彻底搞定信号!【转】
    缓存淘汰算法系列(一)【转】
    缓存淘汰算法 LRU 和 LFU【转】
    NAND Flash标准之ONFI VS TOGGLE【转】
    NAND FLASH学习笔记之nand flash基础(一)【转】
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350903.html
Copyright © 2020-2023  润新知