• 【POJ】[2367]Genealogical tree


    Genealogical tree
    Time Limit: 1000MS   Memory Limit: 65536K Special Judge

    Description

    The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
    And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
    Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

    Input

    The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

    Output

    The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

    Sample Input

    5
    0
    4 5 1 0
    1 0
    5 3 0
    3 0
    

    Sample Output

    2 4 5 3 1


    拓扑排序水题

    给出n行

    每行有以0结束的若干行数字,第i行的数字表示i排在这些数字前面

    所以根据题意进行拓扑排序即可


    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    using namespace std;
    int n,headcnt;
    int cnt[120];
    int topo[120];
    int head[120];
    struct node {
    	int next;
    	int to;
    } a[120];
    void toposort() {
    	int top,t=0;
    	for(int i=1; i<=n; i++) {
    		for(int j=1; j<=n; j++) {
    			if(cnt[j]==0) {
    				top=j;
    				break;
    			}
    		}
    		topo[t++]=top;
    		cnt[top]=-1;
    		for(int j=head[top]; j!=-1; j=a[j].next) {
    			cnt[a[j].to]--;
    		}
    	}
    }
    int main() {
    	while(scanf("%d",&n)!=EOF) {
    		memset(cnt,0,sizeof(cnt));
    		memset(head,-1,sizeof(head));
    		headcnt=0;
    		for(int i=1; i<=n; i++) {
    			int v;
    			while(scanf("%d",&v),v) {
    				a[headcnt].to=v;
    				a[headcnt].next=head[i];
    				head[i]=headcnt++;
    				cnt[v]++;
    			}
    		}
    		toposort();
    		for(int i=0; i<n; i++)
    			printf("%d%c",topo[i],i==n-1?'
    ':' ');
    	}
    	return 0;
    }

    题目地址:【POJ】[2367]Genealogical tree

  • 相关阅读:
    PowerDesigner执行SQL生成模型
    IBM,ORACLE 文档
    JAAS 自定义登陆模块
    JAAS 使用windos登陆示例
    IFRAME跨域
    JAVA RSA 数字签名
    JAVA数字证书
    搭模型时常用的numpy公式,不定时更新~
    Failed to connect to github.com port 443: Timed out
    linux和colab上安装torch_geometric踩坑记录,安装过程
  • 原文地址:https://www.cnblogs.com/BoilTask/p/12569419.html
Copyright © 2020-2023  润新知