• PAT 1062 Talent and Virtue[难]


    1062 Talent and Virtue (25 分)

    About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one's virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.

    Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.

    Input Specification:

    Each input file contains one test case. Each case first gives 3 positive integers in a line: N (105​​), the total number of people to be ranked; L (60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".

    Then N lines follow, each gives the information of a person in the format:

    ID_Number Virtue_Grade Talent_Grade
    

    where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

    Output Specification:

    The first line of output must give M (N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.

    Sample Input:

    14 60 80
    10000001 64 90
    10000002 90 60
    10000011 85 80
    10000003 85 80
    10000004 80 85
    10000005 82 77
    10000006 83 76
    10000007 90 78
    10000008 75 79
    10000009 59 90
    10000010 88 45
    10000012 80 100
    10000013 90 99
    10000014 66 60
    

    Sample Output:

    12
    10000013 90 99
    10000012 80 100
    10000003 85 80
    10000011 85 80
    10000004 80 85
    10000007 90 78
    10000006 83 76
    10000005 82 77
    10000002 90 60
    10000014 66 60
    10000008 75 79
    10000001 64 90

     题目大意:给出排序规则,按照排序规则排序,如果是两个分数均大于H,是圣人;talent分数<H,但virtue>H是高尚人;均小于H且virtua>talent是愚人;其他是小人;且有一个分数小于L的不参与排序,并且按照圣人、高尚人、愚人、小人顺序排列。

    //下面的代码,在牛客网上一点通不过,在PAT上2、3、4测试点过不去,答案错误。

    #include <iostream>
    #include <algorithm>
    #include <vector>
    #include<string.h>
    #include<string>
    #include<cstdio>
    using namespace std;
    struct Man{
        int id,vir,talent;
        int total,type;
    }man[100000];
    //sage=1;nobleman=2;foolman=3;smallman=4;
    int n,low,high;
    bool cmp(Man &a ,Man &b){
        //先这样sort,如果不对的话,那么就按照type再排一下!
        if(a.total>b.total)return true;
        else if(a.total==b.total&&a.vir>b.vir)return true;
        else if(a.total==b.total&&a.vir==b.vir&&a.id<b.id)return true;
        return false;
    }
    bool cmp2(Man &a ,Man &b){
        return a.type<b.type; //这样会保持原来的顺序吗?
    }
    int main(){
        cin>>n>>low>>high;
        int id,vir,talent;
        int ct=0;
        for(int i=0;i<n;i++){
            cin>>id>>vir>>talent;
            if(vir<low||talent<low)continue;
            man[ct].id=id;
            man[ct].vir=vir;
            man[ct].talent=talent;
            if(vir>=high&&talent>=high)man[ct].type=1;
            else if(talent<high&&vir>=high)man[ct].type=2;
            else if(talent<high&&vir<=high&&vir>=talent)man[ct].type=3;
            else man[ct].type=4;
            man[ct++].total=vir+talent;
        }
        cout<<ct<<'
    ';
        sort(man,man+ct,cmp);
        sort(man,man+ct,cmp2);
        for(int i=0;i<ct;i++){
            cout<<man[i].id<<" "<<man[i].vir<<" "<<man[i].talent<<'
    ';
        }
        return 0;
    }

    //关键就是如何将四者分开。柳神是将其存储的不同的向量里。我这种两次sort可能还是不稳定吧。

  • 相关阅读:
    Linux IO接口 监控 (iostat)
    linux 防火墙 命令
    _CommandPtr 添加参数 0xC0000005: Access violation writing location 0xcccccccc 错误
    Visual Studio自动关闭
    Linux vsftpd 安装 配置
    linux 挂载外部存储设备 (mount)
    myeclipse 9.0 激活 for win7 redhat mac 亲测
    英文操作系统 Myeclipse Console 乱码问题
    Linux 基本操作命令
    linux 查看系统相关 命令
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9964216.html
Copyright © 2020-2023  润新知