• PAT 1118 Birds in Forest [一般]


    1118 Birds in Forest (25 分)

    Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive number N (104​​) which is the number of pictures. Then N lines follow, each describes a picture in the format:

    B1​​ B2​​ ... BK​​

    where K is the number of birds in this picture, and Bi​​'s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104​​.

    After the pictures there is a positive number Q (104​​) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

    Output Specification:

    For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

    Sample Input:

    4
    3 10 1 2
    2 3 4
    4 1 5 7 8
    3 9 6 4
    2
    10 5
    3 7
    

    Sample Output:

    2 10
    Yes
    No

     题目大意:给出几张照片,照片中有几只鸟,判断是否在一棵树上。

    #include <iostream>
    #include<vector>
    #include<map>
    #include<algorithm>
    using namespace std;
    
    #define maxn 10001
    int bird[maxn];//初始状态都是0,应该将他们都初始化为自己。
    int exist[maxn];
    int findF(int index){
    //    if(bird[index]==0)
    //        return index;
    //    else return findF(bird[index]);
        int r=bird[index];
        while(bird[r]!=r){
            int t=bird[r];
            bird[index]=t;
            r=t;
        }
        return r;
    }
    void getUnion(int a,int b){//将a和b合并起来,
        bird[b]=a;//这样就合并了呗。
    }
    
    int main(){
        int n;
        cin>>n;
        for(int i=0;i<maxn;i++)
            bird[i]=i;
        int k,t,fa,fb;
        for(int i=0;i<n;i++){
            cin>>k;
            vector<int> vt(k);
            for(int j=0;j<k;j++){
                cin>>vt[j];//应该把这三个都合并起来。
                exist[vt[j]]=1;//表示出现过。
                if(j!=0){//如果不是当前,那么就不能find它的father.
                    fa=findF(vt[j-1]);//这个应该放到Union函数里的。
                    fb=findF(vt[j]);
                    if(fa!=fb)getUnion(fa,fb);
                }
            }
        }
        map<int,int> mp;
        int father,bd=0;
        for(int i=0;i<maxn;i++){
            if(exist[i]==1){
                bd++;
                father=findF(i);
                mp[father]++;
            }
        }
        cout<<mp.size()<<" "<<bd<<'
    ';
        int m;
        cin>>m;
        int a,b;
        for(int i=0;i<m;i++){
            cin>>a>>b;
            if(findF(a)==findF(b)){
                cout<<"Yes"<<'
    ';
            }
            else{
                cout<<"No"<<'
    ';
            }
        }
        return 0;
    }

    //这个AC了,出现的问题在下。

    1.忽略了输出要求,原来是要求输出树的数量以及鸟的总数量;

    2.需要初始化bird数组为i,这个是需要一个for循环的,不可少的。

    3.再次复习了并查集的两个函数怎么写。 

  • 相关阅读:
    Spring MVC- 表单提交
    Ajax提交与传统表单提交的区别说明
    CSS各种居中方法
    Android RecyclerView 使用完全解析 体验艺术般的控件
    如何解决VMware上MAC虚拟机不能上网问题
    input标签的hidden属性的应用及作用
    SpringMVC表单标签简介
    EL显示List里嵌套map(Spring MVC3)返回的model
    Spring3 MVC请求参数获取的几种方法
    写数据到文件,并同步到磁盘
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9870743.html
Copyright © 2020-2023  润新知