• PAT 1037 Magic Coupon[dp]


    1037 Magic Coupon(25 分)

    The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

    For example, given a set of coupons { 1 2 4 1 }, and a set of product values { 7 6 3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

    Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains the number of coupons NC​​, followed by a line with NC​​ coupon integers. Then the next line contains the number of products NP​​, followed by a line with NP​​ product values. Here 1NC​​,NP​​105​​, and it is guaranteed that all the numbers will not exceed 230​​.

    Output Specification:

    For each test case, simply print in a line the maximum amount of money you can get back.

    Sample Input:

    4
    1 2 4 -1
    4
    7 6 -2 -3
    

    Sample Output:

    43

     题目大意:有n个勺子,每个勺子都有一个参数N,有m个积,每个勺子可以和一个积配对,那么求可以产生的最大正整数。

     //就是将两者排序,从大到小,但是有负数怎么办呢?

    代码转自: https://www.liuchuo.net/archives/2253

    #include <cstdio>
    #include <vector>
    #include <algorithm>
    using namespace std;
    int main() {
        int m, n, ans = 0, p = 0, q = 0;
        scanf("%d", &m);
        vector<int> v1(m);
        for(int i = 0; i < m; i++)
            scanf("%d", &v1[i]);
        scanf("%d", &n);
        vector<int> v2(n);
        for(int i = 0; i < n; i++)
            scanf("%d", &v2[i]);
        sort(v1.begin(), v1.end());//从小到大排序。
        sort(v2.begin(), v2.end());
        while(p < m && q < n && v1[p] < 0 && v2[q] < 0) {
            ans += v1[p] * v2[q];//都小于0的相加。
            p++; q++;
        }
        p = m - 1, q = n - 1;
        while(p >= 0 && q >= 0 && v1[p] > 0 && v2[q] > 0) {//这里将0算上了。
            ans += v1[p] * v2[q];
            p--; q--;
        }
        printf("%d", ans);
        return 0;
    }

    //看完题解感觉真的是水题。

    1.将其从大到小或者从小到大排序均可,假设从小到大拍;

    2.那么将左边的负数分别相乘得到结果,右边的整数相乘得到结果即可。

    //emmm,这么简单的吗

  • 相关阅读:
    《JavaScript高级程序设计》笔记:客户端检测(九)
    《JavaScript高级程序设计》笔记:BOM(八)
    《JavaScript高级程序设计》笔记:函数表达式(七)
    《JavaScript高级程序设计》笔记:面向对象的程序设计(六)
    小tips:JS的Truthy和Falsy(真值与假值)
    footer固定在页面底部的实现方法总结
    WEB前端需要了解的XML相关基础知识
    vuex最简单、最直白、最全的入门文档
    原生JS替代jQuery的各种方法汇总
    数据挖掘优秀工具对比
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9602849.html
Copyright © 2020-2023  润新知