• Tempter of the Bone


    Description

    The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

    The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
     

    Input

    The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

    'X': a block of wall, which the doggie cannot enter;
    'S': the start point of the doggie;
    'D': the Door; or
    '.': an empty block.

    The input is terminated with three 0's. This test case is not to be processed.
     

    Output

    For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
     

    Sample Input

    4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
     

    Sample Output

    NO YES

    题目意思很简单,但是有一个很坑的地方。就是给你一个地图,.表示可以走,X不可以走,S起点,D终点,然后给你一个步数num,然后坑点来了,问的是能不能恰好在num步的时候到达终点,步数一定要等于num。

    当然,这道题,如果你直接DFS肯定是会错的。需要剪枝。

    这里只要奇偶剪枝就好。

    //Asimple
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cstdio>
    #include <cstdlib>
    #include <cmath>
    using namespace std;
    const int maxn = 10;
    int dx[] = {-1,1,0,0}, dy[]={0,0,-1,1};
    typedef long long ll;
    int n, m, num, T, k, x, y;
    int endx, endy;
    char Map[maxn][maxn];
    bool vis[maxn][maxn], flag;
    
    bool wrang(int x, int y) {
        return x<0 || x>=n || y<0 || y>=m || Map[x][y] == 'X';
    }
    
    void DFS(int x, int y, int step) {
        if( Map[x][y] == 'D' ) {
            if( step == num ) {
                flag = true;
                return ;
            }
            return ;
        }
        int as = abs(x-endx)+abs(y-endy);
        //奇偶剪枝 
        if( (num-as-step)%2 || as+step>num) return;
        if( flag ) return ;
        for(int i=0; i<4; i++) {
            int nx = x+dx[i];
            int ny = y+dy[i];
            if( !wrang(nx, ny) && !vis[nx][ny] ) {
                vis[nx][ny] = true;
                DFS(nx, ny, ++step);
                //回溯 
                vis[nx][ny] = false;
                step--;
            }
        } 
    }
    
    void input() {
        while( cin >> n >> m >> num && ( n + m + num ) ) {
            for(int i=0; i<n; i++) {
                cin >> Map[i];
                for(int j=0; j<m; j++) {
                    if( Map[i][j] == 'S' ) {
                        x = i;
                        y = j;
                    }
                    if( Map[i][j] == 'D' ) {
                        endx = i;
                        endy = j;
                    }
                    vis[i][j] = false;
                }
            }
            flag = false;
            vis[x][y] = true;
            int as = abs(endx-x)+abs(endy-y);
            //奇偶剪枝 
            if( ( as + num )&1) {
                cout << "NO" << endl;
                continue;
            }
            DFS(x,y,0);
            if( flag ) {
                cout << "YES" << endl;
            } else {
                cout << "NO" << endl;
            }
        }
    }
    
    int main(){
        input();
        return 0;
    }
    低调做人,高调做事。
  • 相关阅读:
    kibana We couldn't activate monitoring
    学Redis这篇就够了!
    elasticsearch 官方监控文档 老版但很有用
    java dump 内存分析 elasticsearch Bulk异常引发的Elasticsearch内存泄漏
    Apache Beam实战指南 | 大数据管道(pipeline)设计及实践
    InnoDB一棵B+树可以存放多少行数据?
    函数编程真不好
    面向对象编程灾难
    可能是全网最好的MySQL重要知识点 | 面试必备
    终于有人把elasticsearch原理讲通了
  • 原文地址:https://www.cnblogs.com/Asimple/p/6172002.html
Copyright © 2020-2023  润新知