• PAT 1109 Group Photo


    Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

    The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;

    All the people in the rear row must be no shorter than anyone standing in the front rows;

    In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);

    In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);

    When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

    Now given the information of a group of people, you are supposed to write a program to output their formation.

    Input Specification:
    Each input file contains one test case. For each test case, the first line contains two positive integers N (≤10^​4), the total number of people, and K (≤10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

    Output Specification:
    For each case, print the formation -- that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

    Sample Input:

    10 3
    Tom 188
    Mike 170
    Eva 168
    Tim 160
    Joe 190
    Ann 168
    Bob 175
    Nick 186
    Amy 160
    John 159

    Sample Output:

    Bob Tom Joe Nick
    Ann Mike Eva
    Tim Amy John

    #include<iostream>
    #include<vector>
    #include<algorithm>
    using namespace std;
    struct student{
      string name;
      int height;
    }; 
    bool cmp(const student& stud1, const student& stud2){
      return stud1.height==stud2.height?stud1.name<stud2.name:stud1.height>stud2.height;
    }
    int main(){
      int n, k, cnt=0;
      cin>>n>>k;
      vector<student> vec(n);
      for(int i=0; i<n; i++)
        cin>>vec[i].name>>vec[i].height;
      sort(vec.begin(), vec.end(), cmp);
      for(int i=0; i<k; i++){
        int t;
        i==0?t=n%k+n/k:t=n/k;
        vector<string> q(t);
        int mid=t/2;
        q[mid]=vec[cnt++].name;
        for(int j=1; j<=t/2; j++){
    	  if(mid-j<0)
            break;
          q[mid-j]=vec[cnt++].name;
    	   if(mid+j>t-1)
            break;
          q[mid+j]=vec[cnt++].name;
        }
        for(int j=0; j<t; j++)
          j==0?cout<<q[j]:cout<<" "<<q[j];
        cout<<endl;
      }
      return 0;
    }
    
  • 相关阅读:
    OCM_第十四天课程:Section6 —》数据库性能调优_各类索引 /调优工具使用/SQL 优化建议
    OCM_第十三天课程:Section6 —》数据库性能调优 _结果缓存 /多列数据信息采集统计/采集数据信息保持游标有效
    OCM_第十二天课程:Section6 —》数据库性能调优_ 资源管理器/执行计划
    使用NuGet时的一个乌龙
    .net调用存储过程碰到的一个问题
    数据库的备份与还原
    创建link server链接服务器碰到的问题及解决办法
    如何管理好项目的DLL
    项目中Enum枚举的使用
    .NET开发知识体系
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9501910.html
Copyright © 2020-2023  润新知