• PAT 1107 Social Clusters


    When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

    Input Specification:
    Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

    K​i : hi [1] hi​​ [2] ... hi [Ki​]

    where Ki​ (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

    Output Specification:
    For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

    Sample Input:

    8
    3: 2 7 10
    1: 4
    2: 5 3
    1: 4
    1: 3
    1: 4
    4: 6 8 1 5
    1: 4

    Sample Output:

    3
    4 3 1

    分析
    参考并查集简析

    #include<iostream> //集合的查并补
    #include<vector>
    #include<algorithm>
    using namespace std;
    vector<int> father, isroot;
    bool cmp(const int& a, const int& b){
      return a>b;
    }
    int findfather(int a){
      int b=a;
      while(father[a]!=a){
        a=father[a];
      }
      while(b != father[b]) {
            int z = b;
            b = father[b];
            father[z] = a;
        }
      return a;
    }
    void Union(int a, int b){ //并集
      int faA= findfather(a);
      int faB= findfather(b);
      if(faA!=faB) father[faA]=faB;
    }
    int main(){
      int N, cnt=0;
      cin>>N;
      vector<int> course(1001, 0);
      father.resize(N+1);
      isroot.resize(N+1);
      for(int i=1; i<=N; i++)
        father[i]=i;
      for(int i=1; i<=N; i++){
        int k;
        scanf("%d:",&k);
        for(int j=0; j<k; j++){
          int t;
          cin>>t;
          if(course[t]==0)
            course[t]=i;
          Union(i, findfather(course[t]));
        }
      }
      for(int i=1; i<=N; i++){
        isroot[findfather(i)]++;
      }
      for(int i=1; i<=N; i++){
        if(isroot[i]!=0)
          cnt++;
      }
      sort(isroot.begin(), isroot.end(), cmp);
      cout<<cnt<<endl;
      for(int i=0; i<cnt; i++)
        i==0?cout<<isroot[i]:cout<<" "<<isroot[i];
      return 0;
    }
    
  • 相关阅读:
    堆和栈 的区别
    equals == 区别
    【知识点】Filter、Servlet、Listener区别与联系
    白盒测试相关的一些知识
    紧急情况下压缩了测试周期应该怎么办?
    软件性能测试与可靠性测试
    软件测试概念
    web测试方法总结
    结对测试探讨
    八种状态增加测试用例状态的精确度
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9501895.html
Copyright © 2020-2023  润新知