• PAT 1050. String Subtraction


    Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

    Input Specification:

    Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

    Output Specification:

    For each test case, print S1 - S2 in one line.

    Sample Input:

    They are students.
    aeiou
    

    Sample Output:
    Thy r stdnts.

    分析
    这道题对s2遍历一遍,用checked记录s2中出现过的字符,对s1进行遍历输出,如果checked中checked[i]==1,则不输出,否则输出。

    #include<iostream>
    using namespace std;
    int main(){
    	int checked[300]={0};
    	string s1,s2;
    	getline(cin,s1);
    	getline(cin,s2);
    	for(int i=0;i<s2.size();i++)
    		checked[s2[i]]=1;
    	for(int i=0;i<s1.size();i++)
    	    if(checked[s1[i]]==1)
    	       continue;
    	    else 
    	       cout<<s1[i];
    	return 0;
    }
    
  • 相关阅读:
    hashlib模块
    configparser模块
    xml模块和shelve模块
    json与pickle模块
    3/30
    os模块
    sys模块
    shutil模块
    random模块
    2月书单《编码隐匿在计算机软硬件背后的语言》 13-16章
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8330711.html
Copyright © 2020-2023  润新知