• hdu 4278 Faulty Odometer


    You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 2 to the digit 4 and from the digit 7 to the digit 9, always skipping over the digit 3 and 8. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15229 and the car travels one mile, odometer reading changes to 15240 (instead of 15230).


    Input  Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 3 and 8.
    Output  Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car.
    Sample Input
    15
    2005
    250
    1500
    999999
    0
    Sample Output
    15: 12
    2005: 1028
    250: 160
    1500: 768
    999999: 262143

    本来是十进制,但是少了3和8,每个位现在都用八个数来计数,4代表的实际是3,5-4,6-5,7-6,9-7,其实就是没以为加够了八个数就会进位,当成八进制了,先把每一位变成他该表示值,那么这个数整个就变成了八进制的表示,转化成十进制就ok。
    代码:
    #include <iostream>
    #include <cstdio>
    #include <algorithm>
    #include <cstring>
    using namespace std;
    char s[10],t[10];
    
    int main()
    {
        while(cin>>s && strcmp(s,"0"))
        {
            int i = -1;
            strcpy(t,s);
            while(s[++ i])
            {
                if(s[i] > '8')s[i] -= 2;
                else if(s[i] > '3')s[i] -= 1;
            }
            cout<<t<<": ";
            int sum = 0,d = 1;
            while(-- i >= 0)
            {
                sum += (s[i] - '0') * d;
                d *= 8;
            }
            cout<<sum<<endl;
        }
    }
  • 相关阅读:
    mysql为什么使用b+树 不使用b树 或 红黑树
    面试篇 CSS
    练习 : Flink 批流一体
    BiliNote使用教程
    (转) DNS各地延迟排行榜(主)
    练习 :Flink 字频统计
    JSON常用方法
    练习 : 自定义sink mysql hbase
    maxWell
    练习:flink table
  • 原文地址:https://www.cnblogs.com/8023spz/p/9002469.html
Copyright © 2020-2023  润新知