• HDU 1242 Rescue(BFS)


    Rescue

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 8065    Accepted Submission(s): 2959


    Problem Description
    Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

    Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

    You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
     
    Input
    First line contains two integers stand for N and M.

    Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

    Process to the end of the file.
     
    Output
    For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
     
    Sample Input
    7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
     
    Sample Output
    13
     
    Author
    CHEN, Xue
     
    Source
     
    Recommend
    Eddy

    //广搜的应用

    #include <iostream>
    #include <stdio.h>
    #include <queue>
    #include <string.h>
    #define N 203
    using namespace std;
    char map[N][N];
    int r[N][N];
    int dir[4][2]={0,1,0,-1,1,0,-1,0};
    int n,m;
    struct node
    {
        int x,y;
    };
    bool is_ok(node &t)
    {
        if(t.x<1||t.x>n||t.y<1||t.y>m||map[t.x][t.y]=='#')
           return false;
        return true;
    }
    void bfs(int x,int y)
    {
        queue<node> Q;
        node a,b;
        int i,l;
        a.x=x;a.y=y;
        Q.push(a);
        while(!Q.empty())
        {
            a=Q.front();
            Q.pop();
           for(i=0;i<4;i++)
           {
               b.x=a.x+dir[i][0];
               b.y=a.y+dir[i][1];
               if(!is_ok(b)||b.x==x&&b.y==y)
                 continue;
                 l=1;
                if(map[b.x][b.y]=='x')
                    l=2;
                 if(r[b.x][b.y]==0)
                  {
                    r[b.x][b.y]=r[a.x][a.y]+l;
                    Q.push(b);
                  }
                  else
                  {
                      if(r[b.x][b.y]>r[a.x][a.y]+l)//发现有更近的、就替换掉
                        {
                            r[b.x][b.y]=r[a.x][a.y]+l;
                            Q.push(b);
                        }
                  }
           }
        }
    }
    int main()
    {
        int i,j;
        int x,y;
        int a_x,a_y;
        while(scanf("%d%d",&n,&m)!=EOF)
        {
            getchar();
            for(i=1;i<=n;getchar(),i++)
              for(j=1;j<=m;j++)
                {
                    scanf("%c",&map[i][j]);
                    if(map[i][j]=='r')
                     x=i,y=j;
                    if(map[i][j]=='a')
                     a_x=i,a_y=j;
                   r[i][j]=0;
                }
           bfs(x,y);
           if(r[a_x][a_y]!=0)
             printf("%d\n",r[a_x][a_y]);
            else
             printf("Poor ANGEL has to stay in the prison all his life.\n");//开始忘记写这个了,又贡献了次//WA,唉、、自己都无语了
        }
        return 0;
    }

  • 相关阅读:
    selenium 在爬虫中的应用
    基于scrapy-redis的第二种形式的分布式爬虫(把普通scrapy框架转成分布式)
    django html 模板继承(下)加精
    django页面之间的前端模板继承或者引入详解(上)
    inclusion_tag 重复页面加载显示模板
    django ForeignKey ManyToManyField OneToOneField
    django建站的注意点
    任务19
    数列求和
    鸡兔同笼2
  • 原文地址:https://www.cnblogs.com/372465774y/p/2581650.html
Copyright © 2020-2023  润新知