• Poj 1611 The Suspects


    The Suspects
    Time Limit: 1000MS   Memory Limit: 20000K
    Total Submissions: 14589   Accepted: 6957

    Description

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
    Once a member in a group is a suspect, all members in the group are suspects.
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    Sample Output

    4
    1
    1

    Source

     
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #define N 30003
    using namespace std;
    int f[N],c[N];
    int n;
    void init()
    {
        int i;
        for(i=0;i<n;i++)
          f[i]=i,c[i]=1;
    }
    int find_set(int x)
    {
        if(x!=f[x])
         {
             return f[x]=find_set(f[x]);
         }
         return x;
    }
    void unin_set(int x,int y)
    {
        x=find_set(x);
        y=find_set(y);
        if(x==y) return ;
        if(x<y)
        {
            f[y]=x;
            c[x]+=c[y];
        }
        else
        {
            f[x]=y;
            c[y]+=c[x];
        }
    }
    int main()
    {
        int m,k,x,y;
        while(scanf("%d%d",&n,&m),n||m)
        {
            if(!m)
              printf("%d\n",n);
            else
            {   init();
                while(m--)
                {
                    scanf("%d",&k);
                    scanf("%d",&x);
                    k--;
                    while(k--)
                    {
                       scanf("%d",&y);
                       unin_set(x,y);
                       x=y;
                    }
                }
                printf("%d\n",c[0]);
            }
        }
        return 0;
    }
  • 相关阅读:
    Ribbon 负载均衡搭建
    MicroService 微服务提供者搭建
    转 Spring boot 集成 Dubbo 快速搭建
    (转)Spring boot 集成Kafka
    转 Spring boot 集成ActiveMQ(包含双向队列实现)
    (转)异步实现服务器推送消息(聊天功能示例)
    (转)Spring boot 配置异步处理执行器
    (转)SSH框架快速搭建(Maven)
    (转)Hbase 操作工具类
    (转)Java AES加密算法工具类
  • 原文地址:https://www.cnblogs.com/372465774y/p/2571976.html
Copyright © 2020-2023  润新知