• Hdu 2119 Matrix 二分图的最大匹配


                            

    Matrix

    Problem Description

    Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .
    Your task is to give out the minimum times of deleting all the '1' in the matrix.

    Input

    There are several test cases.
    The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix. The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.
    n=0 indicate the end of input.

    Output

    For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.

    Sample Input

    3 3 
    0 0 0
    1 0 1
    0 1 0
    0

    Sample Output

    //  比起 网络流 二分图 好学多了 -_-# .....
    #include<cstdio>
    #include<iostream>
    #define M 110
    int mark[M] , m ;
    bool vi[M] ;
    int cap[M][M] ;
    using namespace std ;
    bool find( int i ){
         int j ;
         for( j = 1 ;j <= m ; j++)
             if( vi[j] == 0 && cap[i][j] == 1 )
         {
               vi[j] = 1 ; 
               if( mark[j] == -1 || find( mark[j] )){ // j 没有 匹配  或者找到增广轨 
                   mark[j] = i ;  
                   return 1 ;
               }
         }
             return 0 ;
    }
    int main()
    {
        int i , j , n , sum ;
        while( scanf( "%d" , &n ) && n != 0  ){
            scanf( "%d" , &m ) ;
            sum = 0 ;
            memset( mark , -1 , sizeof(mark)) ;
            for( i = 1 ; i <= n ; i++)
                for( j = 1 ; j <= m ; j++){
                    scanf( "%d" , &cap[i][j] ) ;
                }
    
            for( i = 1 ; i <= n ;i++){
    
                   memset( vi , 0 , sizeof(vi) ) ;
                if( find( i ) ) sum++ ;
            }
            cout << sum << endl ;
        }
    }
  • 相关阅读:
    从尾到头打印链表
    在链表结尾插入一个结点 以及在 在链表中找到第一个含有某值的结点并删除该结点
    替换空格
    二维数组中的查找
    简单选择排序
    冒泡排序
    Hash表的实现
    二叉排序树
    ajax返回后台编译时都对,返回error
    sql删除重复的记录保留一条
  • 原文地址:https://www.cnblogs.com/20120125llcai/p/2987212.html
Copyright © 2020-2023  润新知