• poj3026(bfs+prim)最小生成树


    The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance.

    Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

    Input

    On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

    Output

    For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

    Sample Input

    2
    6 5
    ##### 
    #A#A##
    # # A#
    #S  ##
    ##### 
    7 7
    #####  
    #AAA###
    #    A#
    # S ###
    #     #
    #AAA###
    #####  
    

    Sample Output

    8
    11

    Source

     

     

     

     

    代码

     

     

     

    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    #include<queue>
    #include<algorithm>
    using namespace std;
    int map[300][300],dis[300],vis[300];
    char str[300][300];
    int point[300][300];
    int tvis[300][300],tdis[300][300];
    struct node{
    int x,y;
    };
    int m,n,ans;
    int tnext[4][2]={1,0,0,1,-1,0,0,-1};
    void bfs(int tx,int ty){
         queue<node>q;
         node next,res;
         memset(tvis,0,sizeof(tvis));
         memset(tdis,0,sizeof(tdis));
         tvis[tx][ty]=1;
         res.x=tx;
         res.y=ty;
         q.push(res);
         while(!q.empty()){
             res=q.front();
             q.pop();
             if(point[res.x][res.y]){
               map[point[tx][ty]][point[res.x][res.y]]=tdis[res.x][res.y];
             }
             int xx,yy;
             for(int k=0;k<4;k++){
                 next.x=xx=res.x+tnext[k][0];
                 next.y=yy=res.y+tnext[k][1];
                 if(xx>=1&&xx<=m&&yy>=1&&yy<=n&&!tvis[xx][yy]&&str[xx][yy]!='#'){
                     tvis[xx][yy]=1;
                     tdis[xx][yy]=tdis[res.x][res.y]+1;
                     q.push(next);
                 }
             }

         }
    }

    int prim(int u){
        int sum=0;
        for(int i=1;i<=ans;i++){
            dis[i]=map[u][i];
        }
        vis[u]=1;
        for(int ti=2;ti<=ans;ti++){
        int tmin=2000000000;
        int k;
           for(int i=1;i<=ans;i++){
              if(dis[i]<tmin&&!vis[i]){
                  tmin=dis[i];
                  k=i;
              }
           }
           sum+=tmin;
           vis[k]=1;
           for(int j=1;j<=ans;j++){
              if(dis[j]>map[k][j]&&!vis[j])
              dis[j]=map[k][j];
           }
        }
        return sum;
    }

    int main(){
       int t;
       scanf("%d",&t);
       while(t--){
           memset(point,0,sizeof(point));
           memset(map,0,sizeof(map));
           memset(dis,0,sizeof(dis));
           memset(vis,0,sizeof(vis));
           memset(str,0,sizeof(str));
          scanf("%d%d",&n,&m);
          gets(str[0]);
           ans=0;
          for(int i=1;i<=m;i++){
              gets(str[i]+1);
             for(int j=1;j<=n;j++){
                 if(str[i][j]=='S'||str[i][j]=='A')
                 point[i][j]=++ans;
             }

          }

          for(int i=1;i<=m;i++){
             for(int j=1;j<=n;j++){
                if(point[i][j])
                bfs(i,j);
             }
          }
          printf("%d ",prim(1));
       }
       return 0;
    }

  • 相关阅读:
    MySQL主从复制与读写分离
    使用PHPCMS搭建wap手机网站
    phpcms v9不用下插件自己做留言板
    css关于banner图轮播的实现
    MySql和Oracle的日期转换到底有哪些不同?我们来比较一下
    CSS---解决内容过多就会出文本溢出(显示在区域外面,不换行的情况)
    dedecms 后台发布后的文章不能编辑出现一片空白的解决办法
    python常识系列11-->python发送邮件基础
    python常识系列10-->python代码注释规范
    python常识系列09-->logging模块之handlers的使用
  • 原文地址:https://www.cnblogs.com/13224ACMer/p/4567114.html
Copyright © 2020-2023  润新知