• HDU1198水管并查集Farm Irrigation


    Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

    Farm Irrigation


    Figure 1


    Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

    ADC
    FJK
    IHE

    then the water pipes are distributed like


    Figure 2


    Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

    Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

    Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
     
    Input
    There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
     
    Output
    For each test case, output in one line the least number of wellsprings needed.
     
    Sample Input
    2 2 DK HF 3 3 ADC FJK IHE -1 -1
     
    Sample Output
    2 3
     
    Author
    ZHENG, Lu
     
    Source
     
    Recommend
    Ignatius.L
     
     
     
    解题思路
    并查集分类问题,将其分堆,等于本身的便是总共的个数

    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    char a[55][55];
    int pd[2505];
    struct node
    {
        int l;
        int r;
        int u;
        int d;
        int num;
    }que[55][55];
    int get(int x)
    {
        if(pd[x]!=x)
            pd[x]=get(pd[x]);
        return pd[x];
    }
    void find(int x,int y)
    {
        pd[get(y)]=get(x);
    }
    int main()
    {
        int m,n;
        while(scanf("%d%d",&m,&n)!=EOF)
        {
             if(m==-1&&n==-1)
                break;
                if(m==1&&n==1)
                {
                    printf("1 ");
                    continue;
                }
            memset(pd,0,sizeof(pd));
            memset(a,0,sizeof(a));
            int N=n*m;
            for(int i1=1;i1<=N;i1++)
                pd[i1]=i1;
            getchar();
            for(int i2=0;i2<m;i2++)
            {
                for(int j2=0;j2<n;j2++)
                    scanf("%c",&a[i2][j2]);
                    getchar();
            }
            int h=1;
            for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
            {
                if(a[i][j]=='A') {que[i][j].l=1;que[i][j].r=0;que[i][j].u=1;que[i][j].d=0;}
                else if(a[i][j]=='B') {que[i][j].l=0;que[i][j].r=1;que[i][j].u=1;que[i][j].d=0;}
                else if(a[i][j]=='C') {que[i][j].l=1;que[i][j].r=0;que[i][j].u=0;que[i][j].d=1;}
                else if(a[i][j]=='D') {que[i][j].l=0;que[i][j].r=1;que[i][j].u=0;que[i][j].d=1;}
                else if(a[i][j]=='E') {que[i][j].l=0;que[i][j].r=0;que[i][j].u=1;que[i][j].d=1;}
                else if(a[i][j]=='F') {que[i][j].l=1;que[i][j].r=1;que[i][j].u=0;que[i][j].d=0;}
               else if(a[i][j]=='G') {que[i][j].l=1;que[i][j].r=1;que[i][j].u=1;que[i][j].d=0;}
               else if(a[i][j]=='H') {que[i][j].l=1;que[i][j].r=0;que[i][j].u=1;que[i][j].d=1;}
               else if(a[i][j]=='I') {que[i][j].l=1;que[i][j].r=1;que[i][j].u=0;que[i][j].d=1;}
               else if(a[i][j]=='J') {que[i][j].l=0;que[i][j].r=1;que[i][j].u=1;que[i][j].d=1;}
                else {que[i][j].l=1;que[i][j].r=1;que[i][j].u=1;que[i][j].d=1;}
                que[i][j].num=h;
                h++;
            }
            for(int i3=0;i3<m;i3++)
            for(int j3=0;j3<n;j3++)
            {
                if(j3<n-1)
                {
                    if(que[i3][j3].r==1&&que[i3][j3+1].l==1)
                        find(que[i3][j3].num,que[i3][j3+1].num);
                }

                if(i3<m-1)
                {
                    if(que[i3][j3].d==1&&que[i3+1][j3].u==1)
                        find(que[i3][j3].num,que[i3+1][j3].num);
                }
            }
            int sum=0;
            for(int i4=1;i4<=N;i4++)
            {
                if(pd[i4]==i4)
                      sum++;
            }
            printf("%d ",sum);
        }
        return 0;
    }

  • 相关阅读:
    FTDI端口或ISP端口编程方式的比较
    PhantomX Pincher Arm---设置ArbotiX和Arduino软件
    PhantomX Pincher机器人机械臂那些事儿
    使用aplay实现音频播放
    TurtleBot3-讲在前面的话
    ROS-ROS命令(五) rosservice:ROS服务
    ROS-ROS命令(四)rostopic: ROS话题
    ROS-ROS命令(三)ROS 信息命令
    jquery下拉框应用
    jquery的attr获取表单checked 布尔值问题
  • 原文地址:https://www.cnblogs.com/13224ACMer/p/4393346.html
Copyright © 2020-2023  润新知